Google Assistant: "Could not update settings" / "/api/error_log served" if more than a certain number of my devices are set to be sent

Tags: #<Tag:0x00007f73a573f620>

there is indeed a limit, i am now deleting some entities, if i do a “sync my devices” after a restart, if i have no error then, then i am good, or maybe i can figure out what the corrupt entity is… although, i dont think there is not a corrupt one…

i am now trying the HA Cloud, same issue on linking
but i see everything is exposed as default ;, this line doesnt work on the cloud edition : expose: true
so i am not sure how i need to exclude entities in cloud to test and limit the entities

but anyway, my first test on HA cloud when eveything is exposed, also gives an linking error
so now trying to exlude stuff, but lots of work

ok, exposed all domains, except 1 in HA cloud, this was my cover: domain, it only had a few entites, now HA cloud links fine!!!

so, what do we now? not an issue in google assistan component? but related to 88.x? or google?

I’ve tried downgrading to 0.87.1, and am getting the same issues then. So not 0.88. I also restored a hassos snapshot from January 29th with 0.86.3 and had the same issue there, and I know I relinked it since then because I added a couple of new devices a week ago, so I think that rules out any local data corruption.

If you are getting it with cloud, and I am with older version, then I guess it must be google’s end. Either they broke something, or changed something that HA is using. sigh

ok, verry frustating , i noticed this day earlier, when a specific light didnt work anymore, while the rest was working fine, … google home gave me always an error when i turned the light on off … even from the home app itself
so thats why i unlinked and tried linking again

i wonder if it has something todo with this google issue, there is an issue, that you cant enable testing anymore in the simulator, so you need todo it with a console now


maybe google is changing something

created an issue here : https://github.com/home-assistant/home-assistant/issues/21373

ok, testing with HA cloud, wanted to go that way anyway, seems limit is indeed about 20 entities, one more, and BAM sync issues, doesnt mather the domain

After more testing I agree with your findings.

19 entities, no matter what they are, it works. 20 and it doesn’t.

Weirdly, sometimes when it has worked it gives me the error anyway, but if I swipe down to refresh it shows [test]Home Assistant as a linked service, or if I ask google assistant to do something. But only if less than 20 items are added. More than 20 is actually not working, not just the error appearing when it worked. Explains why it didn’t seem to be a number limit when I first hit the problem last night if sometimes it gave me an error even when it worked.

Also noticed that right now nothing linked from HA is actually showing in my “Home” app’s rooms. Google Assistant can use them, and knows which rooms they are in, but their app doesn’t seem to be showing them.

yes, indeed same issue, here, they are not in the “home” anymore
i tried deleting the home , doesnt work either

serious issues it seems

i have now 19 devices in HA Cloud, and 19 devices in HA Local, so back up to 38 devices :slight_smile:
had to drop a few though

I’ve managed to cut down to 19 devices I absolutely need (all of which are lights), just a little less granular control, and no voice control over automations/access to the temp sensors I have around the place, etc. But the family likely won’t notice now.

Guess I might think about which of the 30ish remaining ones might be worth doing via HA Cloud at least until google sorts their stuff out (or someone spots what they’ve changed in the spec that HA isn’t doing right).

well, for me at the moment, i dont see them anymore in the home app, but they are linked
but cant control them anymore either ;(

@Lastof are you using aliases? Yes, maybe that’s the issue, in the other thread, @DavidFW1960 is only one that is able to sync with more then 20 devices

I doubt that’s it. Google is getting the friendly name from customize… I can’t use the device_id to control them… Google only knows the friendly name.

No, aliasses we’re working perfectly before,. They were not visible though in the app, but definely working… Sometimes I had like , 15 different aliasses for 1 entity, even mixing languages were possible…

Used them a lot … Control the same entity with different words or sentence

Gonna drop the aliasses later, to see if that was the culprit, the only difference I see in your config

For example, for a exposed cover : screen

I created aliasses, like window, shutter…

So I can say, screen down, shutter down, window down…

@Lastof @DavidFW1960

what i also see as a difference besides aliassess
in your config David: https://github.com/DavidFW1960/home-assistant/blob/master/google_assistant.yaml

you dont use this line : expose_by_default: false
so if you expose a domain, you need to exclude every single entity in your config file , otherwise it will be visible?
we work the other way we use this line : expose_by_default: false , and just exlude = true for each entity, this is less work

EDITED POST :
@Lastof
one step further
removed all aliasses , but same issue
but what works, but only with the paid version, make sure if you link the hass.io app, that devices are below 20 , then link, then you can expose entities in your config, then sync my devices, thats seems to be working, just make sure you dont unlink again…
btw, entities are still not visible in the home app on android, but at least i control now my stuff

Perhaps but this was how I originally configured it. I also specify the room for each entity anyway.

I specify these in Google instead of home assistant… use them with routines.

That’s also an approach, but routines is not yet available for all countries, we are still waiting for it… But anyway, it has nothing todo with aliases, I ruled that out

Yes I very much doubted it would be that.
None of this makes any sense and it’s only people here on HA who are complaining about this so I don’t see that it’s even a Google problem. It’s very weird that ‘cloud’ seems affected as well. Are you on 0.88 of Home Assistant?