Google Assistant trouble shooting

Tags: #<Tag:0x00007f73b32cea38>

I am trying to get google assistant working. I followed these 3 tutorials but non succeeded:

When I try to test/simulate/create draft I get the following error that I can’t seem to fix or understand:

GoogleFulfillment ‘actions.fulfillment.devices’ is not supported

I hope anyone know how to fix this, its driving me mad

credits to @dpalita for the working solution:

There is a manual workaround:

  • download the gactions cli at https://developers.google.com/actions/tools/gactions-cli
  • authenticate with any command eg:
    ./gactions list --project [YOUT_PROJECT_ID]
  • download the json representation of your action:
    ./gactions get --project [YOUR_PROJECT_ID] --version draft > action.json
  • edit the json to 1. extract the only object from its array, 2. remove the nested “googleFulfillments” object
  • push your fixed action into test:
    ./gactions test --project [YOUR_PROJECT_ID] --action_package ./action.json

This replaces the step 3 " Click Simulator under TEST " in the google assistant manual setup. And then it seems to work

3 Likes

Having exactly same prob. Busy for last 2 hours with this :frowning:

google_assistant.request_sync no longer functions for me on 0.87.x - this was working previously since I implemented back in 0.84.x. Now, I’m getting an HTTP 400 (not 404) error now. I feel like there’s a permissions issue related to the www folder.

I am also seeing the same issue. Followed the guide word for word. 0.87.1

Guys, you know that the component doesn’t sync anymore after 30 days? That’s a limitation…
You need to make a new draft in the simulator and then link again

I think we’re at the part where we’re creating drafts. I created a brand new project, have it all setup to the wiki. Running my first test i get this error:

Checking the network trafic i’m seing that https://console.actions.google.com/u/1/m/actions/agents/draft/createlocalizeduserpreview is returning with a 400:
1. code: 400
2. customCode: 9
3. errorSpace: “generic”
4. message: “GoogleFulfillment ‘actions.fulfillment.devices’ is not supported”
5. status: 9

1 Like

Same error here, it keeps facing no matter what I try. Someone had any luck with it?

I have the same error

I habe the exact same.

Seems this is something really weird.
In the whole Google there are ONLY two references of this error message. This page and another one in French.
So, I guess this is something new. Could it be that Google has chnaged something in their Actions?

i am afraid to create a new draft , we have todo this every 30 days :frowning:

What do you mean create new draft? I just go into the project I created a year ago and re-enable testing/simulation) I have lost count of the number of times I have done this now…

yes, see you mentioning this a few times in other threads? how do you enable testing again, i always change the draft version, see screenshot
after that i always need to unlink / link again
where is that re-enabe testing button? :slight_smile:

1 Like

I’m also having the same problem, seems like it started happening yesterday to everybody.

Looks like google knows it’s an issue: https://developers.google.com/actions/support/known-issues

2 Likes

Same problem here. Today, of course, being the day I thought I would delete my separate Google Projects and combine all my Home Assistant integrations into one single project…

…grrrrrr.

last update from 01/16/19 one month and gg no fix it? I got that error :frowning:

This is my first time with home assistant, and I thought that I was doing something wrong, I was just going to throw the towel with HA when I found this post…

1 Like

Yes, that’s concerning isn’t it.

Time to move over to HA official cloud :wink: