Google Assistant integration not working anymore

Hi all,
I setup my Home Assistant to work with Google using the manual steps listed here
Everything has been working like a charm for a month.
Yesterday I had a problem: commands were working properly but I could not resync devices.
So I read around and I decided to unlink/link the services againg and now I’m not able to have it working.
I finally deleted all the google stuff and created a new project and new API Key. Now, I see the custom app, but when I try to link it I get to the login page, I do login everything seems to be working properly, but I cannot see anything in my Google Home application.

How can I debug on the Google Cloud side?


Ok I think I found the problem, and it seems to be related to google itself.
If I try to sync devices it reports and error synching with my old [test]App and Philips Hue, both of which have been unlinked and does not show as linked!!!
It there any way to force disconecting them?


I had the same issue, somehow my app was corrupted…
So started a new project, new app, deleted the old one on Google project site, and after max 30 days the old app is gone

Also check in your Google project sitew if you still have a draft version, normally you should start the simulator

I had a similar problem, right now. and I was watching this thread.
Unlinked the [test] but couldn’t relink it (Stupid, useless error “Check the connection”).

I went to and started a simulation.
It linked immediately, after that.

No need to delete and recreate the project.


Hmm, seems also issue here now…
Problem synching with …
When I run sync my devices

Still problems here, too
I can link, I can sync but if I try a command it says “The device [test] - MyApp is not available”.
After the error I can’t sync anymore.

Ok, I fixed it, I also had an errror linking again
Unlink, then create a new draft version on console site, then link again

Seems those drafts are limited on time or something

According to the documentation Google Test Simulations are active for a max of 30 days. How do we make this permanent?

You can’t. You need to re-enable testing/simulation every 30 days. Takes a minute. Maybe set a reminder so it doesn’t stop working unexpectedly…

To be more precise you can actually publish the app but that is not an easy thing to do and I don’t even know if it’s practical for a one-off use for you… it’s intended for people like Xiaomi etc to make their integrations to their cloud available through GA, not for users like us…

If I re enable testing, I always need to unlink and link the test app again, is that normal behaviour?

Is it a Google Home device?
Had the same issue before. Contacted Google and they suggested a factory reset of the device.
Relinked and everything worked again.

Has nothing todo with hardware, those guys at Google support always tell you todo a reset…
Most of the times they are bots

Just saying that it did the trick for me…

The factory reset is standard… what worked was relinking

It’s not hardware related, you don’t need to have an hardware home device, since the test app of HA is on your Google home app linked, in Google assistant… And not on your home device…

So, the correct thing to do is re-enable the test AND unilink/linking again?
Or just re-enable the test?
I am asking because sometimes linking could be a mess ( some things seems not synchronized on Google server side) and need waiting a day in order to have a clean situation!

In my case, after re enabling the test, I always need to unlink and link again

I’m not sure to be honest… I seem to recall I just re-enable simulation/testing without needing to relink…

I had ONE occasion due to a Google Error that I ended up with everything duplicated but that was once and only for a day.

1 Like

Awesome, thanks for this advice, worked like a charm!

Started a simulation and it worked again for me without having to do anything else.

1 Like