Google Assistant Issues

Hi and thank you in advance for reading my post.

I’ve been using HA with Google Assistant for several months, occasionally an upgrade to HA or a new device seems to break the sync and I either lose the ability to control the devices or sync new devices added to HA into Google Assistant.

Right now the integration is working, sporadically, occasionally I’m getting the GA Project “Home” is not available.

When I log into and try the simulator it works occasionally, but I always get this response.

“We’re sorry, but something went wrong. Please try again.”

Both of these requests worked and turned on the lights, but return these errors?

Can anyone tell me if I’ve got something setup incorrectly or there is some obscure setting thing that I’ve overlooked?

Thank you again for assistance, I try my best to pay it forward!

Any similarities to this, are you using duckdns?

Yup it’s happening to me too… guess it’s duckdns that is having some issue then…Does anyone know for any reliable alternative to duckdns?

Could get a paid domain name. My issue is that I need SSL for google assistant to connect and I use port 80 for a different server so can’t forward it to hassio to renew with let’s encrypt. The duckdns add-on doesn’t need port 80 to renew.

That thread looks like it’s more related to duckdns, which might be the culprit, but what about the specific errors that the simulator gets back when it talks to HA? It seems odd to me that it’s constantly receiving an error message when it communicates with my HA installation?

When you say it’s happening to you also… are you seeing those exact same errors in the Google interface?

I got sick of the Google Assistant integration constantly breaking sync and switched to HA Cloud. It has been pain free ever since. Obviously this then comes at a monthly cost, but for me was worth the time saved trying to fix it every month.

I am experiencing the same results. HA access via google has become unreliable and fails about 30 - 40 % of the time., either by voice/google assistant or Google Home app this has only been happening for the last couple of days. I just keep trying and it may work on the 3rd try or sometimes the first try no real pattern. Everybody is jumping to a conclusion that there is a duckDNS issue. I’m leaning more towards Google has some issues ? or made some “enhancements”. When I remotely connect to my home assistant ( https via duckDNS ) everything works EVERY time and is very snappy response, ie more or less instant response to switch a light on or off. Not so much when I use google home or assistant.

As troubleshooting step I have tried direct HA remote access at the same times Google Assistant was not working. So far that works 100% of the time. I was thinking it might be a latency issue. The Google assistant site say 200 ms is ideal, but most of the time 2-5 seconds should work

I’m still pondering how to proceed.

I had a string of 10 failures back-to-back maybe 20 in a row last night… despite this working for 18 or so months with hardly a miss. I actually think it’s a Google issue as I am not seeing any problems hitting my HA instance in a browser… doubt it’s duckdns… could be wrong but it smells like a Google issue to me.

1 Like

Same here. I don’t think its coincidence either that they just released their Max Hub within the last few days either. Anytime Google does something big its usually around a release or announcement. They are gearing up for something.

I don’t use google but I’ve been having issues connecting to HA over the last night… Are you sure it’s not related to DDNS? That’s the only thing I can think of. This all started for me sometime between 3:30pm EST and 8:30 PM est. So about exactly 24 hours ago.

Dunno Petro… I have zero issues connecting via duckdns internally or externally… has not missed.

I have had issues connecting via duckdns to my HA but not as often as Google is having issues. I am getting the same problem where I need to keep trying several times. I suspect DNS propogation issues. Google will use random servers each time you make a request so fails more often. At home it will always work as the router will just do not loopback/reflection.

When I said it was happening to me too I meant that my Google assistant said it could not reach my test app (not sure exactly what words it uses in English since mine is set to Italian). However last night I edited the CNAME DNS record of my domain that pointed to duckdns and now it’s seems that the issue has gone.

Can you please explain what you did to resolve it?
I didn’t understand what you wrote.

Short Version:
Basically what I did is get rid of duckdns and use another way to point to my home assistant instance.

Long Version:
I have a paid web domain with a hosting company many months ago in their dns admin panel I created a subdomain that would point to my duckdns name. What I did last night was edit this record and point it directly to my public ip address bypassing duckdns.

Hope that makes it clearer.

So today it’s been solid, but still in the test emulator thing I receive those original errors, wish I new why and if there is something missing in my config that causes this.

I guess I’m a little confused, adding devices that have some sort of oddity such as a while ago when Google required a new device class of “Speaker”, I immediately lost control of my Yamaha receiver until this was fixed. How does HA Cloud solve this, doesn’t GA integration still have the same requirements of device classes domains etc, that would cause the same issues? I get that it’s not Dynamic DNS and it creates basically a secure tunnel to your HA instance, but other than that I’m not seeing how it makes the integrations more reliable?

I wouldn’t get hung up about messages in the simulator.

It seems to me there are 2 possibilities for the problems over the last few days. It seems google had issues connecting to ha hosted on duckdns domains. I am pretty sure this was a google issue rather than duckdns but maybe it was the combination of the two.

In any case for around 12 hours now I haven’t had a miss.

HA Cloud for me has mainly just meant that the Google Assistant component doesn’t keep losing sync where I was previously having to unlink / re-link in the Google Home app a lot, and often also stop / start the ‘test’ project in Google. I would usually only be successful at using the google_request_sync service once before it would then fail and need a heap of mucking around to get it sync’d again. HA Cloud keeps all devices nicely synchronised without any effort on my side