Google Assistant not linking anymore

It was working until 1 hour ago.

I updated to 0.57.3 and updated to the new Google Home app

Then I unlinked and relinked, and now is not linking anymore (at the end the message is Succesfully linked, but its not)

How to troubleshoot?

Hmm. It’s all still working here. Updated Google Home app on iOS

nope my totally broken now.

I redid all the installation with new app in google developer console. Same result

you have Google Home app

Google Home App on my iPad is version 1.26.709 (ditto on my iPhone.
Google Assistant version is 1.1.5316
Firmware of my Google Home is 99956
Firmware of my GH Mini is 100429

This is driving me mad.

Now it added 1 device (I have around 100)

If I unlink and relink I again have zero devices.

Anyone has a clue?

Every time I unlink and re-link my HA to GA, I have to rename at least one of the aliases of every entity connected or they will not show up.
So, under every entity I added a line like:

  • entity a 1
  • entity a 2
    Which will be renamed in
  • entity b 1
  • entity b 2
    And so on…
      icon: mdi:lamp
      google_assistant: true
      google_assistant_name: table
        - light on the small table
        - entity a 1
      icon: mdi:spotlight-beam
      google_assistant: true
      google_assistant_name: library
        - light on the library
        - entity a 2
      icon: mdi:ceiling-light
      google_assistant: true
      google_assistant_name: spotlight
        - lights on the black library
        - entity a 3

Mmhh but my settings was working before, without your solution.

Anyway I will try this, but having to do to all my devices is a pain

Will try.

But why is this needed, you have a clue?

When did you start this, how long ago?

Well, actually in my case it started since a couple of weeks after I installed the component. It looks like the GA after “successfully linking” shows only the new entities. Well, yes, it takes a bit to add that alias name to all the entities you want to use, but only the first time. After that you can use “replace all” in your editor

mmhhh it might be my case, he thinks the devices are already inside. ANd so you solved by adding aliases so GH thinks has to update all the devices, yes?

If so should be possible to make GH forget all devices somehow… no?

EDIT. YES that’s the solution

With the new REFRESH option upcoming, this should be solved, hopefully

mmmh… inside the GA app there’s no way to delete them.
oh, right, on the iphone app there should be this “refresh” option, right? On Android still nothing, that’s weird…

I think is a function that HASS developer need to add, and it should come in next version.

But I am not sure that will FORGET devices and readd them, or just a refresh to add new items. In this latter case the problem will persist

check this thread

Hey no it did work on one. Now I changed 58 devices, and … it did not add them … which is your google assistant configutarion in configuration.yaml?

  project_id: hassio-xxxxx
  access_token: longer-numberxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    - light

Sometimes you have just to wait a few minutes…

what do you mean, redo it?

Now I have as entities in GH only entity a 1, entity a 2…
And not the name and not the second alias

Such a crap

No, you better use two aliases for every entity, the first one will be shown on GH and the purpose of the second one is only for the renaming. I just don’t understand why GH doesn’t show in the list the google_assistant_name. No, sometimes I had to wait a few minutes and they just appeared, without redoing the procedure.
Now, just to be sure, add a second alias and rename every “- entity a” with “- entity b”, restart the home assistant, then go on “”, click on “Test draft” and then remove and add again your HA from the GH. That’s what I do every time my devices doesn’t show up