Google Assistant Question

I just switched to android and am trying to get google assistant to discover my devices. I had no problem with alexa but I see many topics on this. I have tried just about everything I can find and I believe Im right on the tip but need some help. I have created all the stuff in actions and see the account in google assistant to add. When I touch the account it flashes a few screens and then comes back and says “couldnt update the setting, check your connection”

I doube checked everything and it looks good does anyone have a solution to ths?

My client IDs were randomly generated and put in actions and my ha config. the auth url I have tried both

Im not sure that is where the problem is but i thin so…

Did you enter an IP address in place of xx.xx.xx?
Reason I’m asking is that one would normally get a name from duckdns or the like so I don’t understand why you would enter an IP address.
Also have you confirm you can access your HA frontend from outside your network when you enter https://xx.xx.xx in your browser address bar?
Can you maybe share a redacted copy of your google_assistant config?

I just xx’d out my ddns name. my ddns works fine…do you have yours working? ever see that error? thanks

Mine works fine, no errors.
You should indeed use https://xx.xx.xx/api/google_assistant/auth?api_password=mypassword during the setup
You may want to try again from scratch as possibly something didn’t right at some stage?

thanks, yea I am pretty much at a loss thats a good idea. I will try that

I can see it talk to my home assistant, it just flashes so quick back to the page where you click the skill or whatever google calls them. its gotta something in the client id or secrect or token or ssn or blood they want for this to work lol

FYI only issue I “ever” had was to set expose_by_default: false and not adding expose: true for each entity under entity_config:
after the few screens I’d get “accounts are not linked” message but nothing showing up.

i think i ran across your post while searching I seen that mentioned. I have that line, I only want a couple entities exposed.

Ive tried many things but this was my last attempt and where Im getting that error:

  project_id: -id was takin from the actions site where it says project id
  client_id: -random generated with matching random generated in actions
  access_token: - taking from actions page
  api_key: - takin from action page
  expose_by_default: false
      name: Garage
        - Garage Door
      name: Fireplace

Try adding the port to your server (8123 in most cases).
Also try to turn off your device wifi during the processus.

turn off wifi where at? from my laptop or the APs in the house? HA runs on an ubuntu vm

8123 wont get through only 443 gets routed to 8123. i guess i could try to forward 8123 to 8123 but I dont see how that would be different

yes check my message just posted :smiley:

I seen that message, am i missing something obvious? :slight_smile: oh shi…man

so you use exposed_by_defaut: false but then expose: true so like this?

expose_by_default: false
      name: Garage
      expose: true

The wifi of your Android device, sometimes it needs to access ha from outside of your lan.

About the port thing, check this post/topic.

thanks. I did try to add :8123 with no luck but I really dont see that being differnet. i will try to add what you suggested, forward 8123 and turn wifi off real quick. be right back, thanks for taking the time to help!

yes, else nothing will be displayed. It’s not 100% clear on the doc and I’ve submitted a PR for it (4936)
It doesn’t look like it’s your issue for now (would defo have been in the future tho) as you have a different error message, hence the suggestion to try again from scratch

yea no luck i tried all of thise and same thing. I get that messege at the very bottom for a second. and I just noticed i could see that quick flash/redirect. it says “return to app”

I am going to start from scratch.

Ok good Luck then.
I’m on my phone so can’t check my config, will try to post something that Can help tomorow.

Well look at this, I see account is now linked!!! Only, my devices arnt in there and the app is still under link accounts like its not linked, unless it just stays in there…

Bingo! Now make sure you’ve exposed your entities.
Which version of HA are you running?


Did you see anything wrong with the config I posted? Those entities work fine I use them all the time from dashboard or Alexa.