Google coral + Synology VMM

Today i have receive my Google Coral.
I have HA on a VM on Synology.
I have setup the usb device on Synology VMM but in HA, hardware not apear the coral device.

Nobody use Google Coral with Synology VM?


I have no knowledge of hypervisors on Synology, but in general you need to attach USB devices to the specific VM.
USB devices are dedicated devices, so multiple VMs can not use it at the same time.

Yes, i have already a SONoFF USB Zigbee stick attach to my VM and working great.
Now i have attach the Google Coral too, but not appear in HA.

Have you looked in the hardware overview?
A Coral stick is probably not autodiscovered, since HA has no use for it.

Yes, i think it is not autodiscovered, because in hardware overview i only have my Zigbee stick and nothing more.

How to discover the Google coral on HA?

I should still list somewhere under hardware.
If it does not do that, then it sounds like the VM is not configured correctly.

Today, i tried to export my VM to my computer to do some test.
I have the same issue with VMware Esxi, The google coral is not reconized on HA hardware.

Question - what is your expectation? When HA recognises Google Coral, it will…
HA doesn’t support Coral (at least not now) and there is nothing HA will benefit with Google Coral available. Just wanting to make sure your expectations are possible…

I want to use Frigate with googe coral but my google coral is not reconized in ha hardware.

It works fine with Frigate AddOn in Synology, not reliable, but when it works it works.
Did you map the device to VM in VMM manager? It will not first time have Google Coral name.
When you start Frigate, it will disconnect and you have to add it once again in VMM but this time it will have Google Coral name.
And it will work for 2 to 222 minutes, depending on how lucky you are but it will auto-disconnect after some time and you’ll have to physically reconnect to Synology and repeat the process.
And no, you don’t need to see it in HA. HA can’t do anything with it.

Hey there,

i have 2 USB coral sticks connected to my Synology NAS running Hassio in a VM. As you described, the USB connections have to get established, prior to that the sticks are not named google coral. After initialisation (which normally happens with magic after a couple of minutes), the sticks can be added in your VM properties. My system is running them properly without any timewise restrictions, once its initialized, the sticks are running well “for ever”.

Useable in frigate so far.
Best greetings,

Just received google coral usb and a board which I cant remember how its keyed lol. I am seeing alot of mixed reports about getting this working.

  1. What version of DSM are you using?
  2. Any tips from you on why you think you were successful

not working for me doesn’t seem to create the proper device when passed through on dsm 7. I am trying to use the usb version

Hi David,

I run on the very latest DSM version. Always up to date.
The only tricks I can tell is to go to the preferences of the virtual box of your hassio appliance and try to load and unload the virtual USB ports. Somehow magically its working after a time… Maybe, and this I had by my second synology NAS, you need to add a separatly powered multi USB adapter at the NAS, because the NAS does not supply the coral stick with enough power. But with my new Rackstation, its working without the adapter.
Hope this helps


1 Like

Interesting about the separately powered multi usb hub. I was doing some reading about it and it suggested that it wasn’t a power problem(although it certainly could be) but that the whole controller would be passed through to the VM, making it work.

Do u remember or could you check what you are passing through(the actual name) in the DSM VM application on the multihull powered hub Synology machine. Also what brand of multi hub adapter are you using. I might as well see if I can get that one and not reinvent the wheel.

Much obliged

Hi David,

i looked it up.
The name, which is passed through to the VM is:
its not this other name, If it does not show google, its not working!
For the USB hub, I bought this one here:

Its nothing really sprecial… But maybe it helps…
Lots of greetings.


Does the Kexin USB Hub solve the issue? Or did you find another solution?
I have exactly the same problem with the TPU stick. I tried with a “good” TP-Link powered Hub, no avail. The TPU still does not show as Google Device, regardless on where i plug it and how many times i reboot.

I’m somewhere in the middle of way. Do not see hardware in HomeAssistance.
HUB: 4 Ports Powered USB 3.0 Hub without additional power (tried both, no difference).
Synology DS918+

Thats my best I got from HA:

Tried everything. Seems like Synology not understandig corretly the device, as a result its not correct name/id/… in HA and Frigate can’t understand the issue.

Might be some changes in Frigate code is needed.

What I usually did was to start frigate with device initially visible as Global Unichip and it would shutdown. After that in VMM, name of device device was changed to Google Coral - had to reselect it and it worked (for few minutes or hour) until it got disconnected and had to repeat the process.