Google Home - Emulated Hue - Voice Control

Hi All,

I have read a heap of posts regarding the setup of emulated hue and I don’t know if I have lost track somewhere or what but I was hoping someone can provide a bit of guidance.

My objective is to use my Google Home to provide voice activated control of everything I have setup in Home Assistant. I thought that by setting up emulated hue I would be on the right track, but then got confused between it and HA bridge… do I need both? what is the setup flow of all this to get voice activated control of Home Assistant via my Google Home? Do I need to create each item from Home Assistant within the Google Home app on my phone to link them all together? I tried by installing HA bridge and adding 1 light, but then the Google Home app on my phone started showing 2 lights of the same name…neither of them actually worked when I tried to control the light

this is the main post i tried to follow to get it set up:

You dont need HA Bridge.

Enable emulated Hue - making sure it is running on port 80, and expose by default is false to stop everything being exposed

  listen_port: 80
  expose_by_default: false

then in customize, turn on the things you want to control, i.e

  emulated_hue: true
  emulated_hue_name: "tv"
  emulated_hue: true
  emulated_hue_name: "foxtel"
  emulated_hue: true
  emulated_hue_name: "media centre"
  emulated_hue: true
  emulated_hue_name: "chromecast"
  emulated_hue: true
  emulated_hue_name: "silver lamp"

Restart HA and make sure you can hit in your browser

http://<HA IP Address>/description.xml
http://<HA IP Address>/api/pi/lights

and that you can see all the ‘switches’ that you enabled in customize.

Then open the Home app, add Philips Hue and it will load in all your entities. You dont need to add rooms nor rename anything in the app. Then use the name you used in customize for control, i.e.

Hey Google, turn silver lamp off

Hope that helps

1 Like

Awesome. Thank you so much. This is much clearer! I will give it a try next week when I get back from work

Unfortunately with recent updates to Google Home app, emulated_hue no longer works !

Check the thread at Google Home Hue Setup Change?

To summarise the issue:

  • This is true for any new setups using Google Home app (on android or ios) + Google Home
  • Trying to add “Philips Hue” as a Home automation device in Google Home app will result in you being redirected to Philips Hue login page (see the above mentioned thread)
  • Local discovery of Hue hubs has been disabled in the app

I really hope someone can fix emulated_hue or come up with an alternative. Siri works perfectly with homebridge but really want Google assistant (on phone and Home)

Unless I’m getting things mixed up again, I thought I read that you can use an old APK of the Google Home app to do the initial pairing of the physical Google Home and Home Assistant. That’s what I did to get to where I am now. As far as I can see it worked, but I’ll need to wait until I get back home next week to make the other changes required that I had missed in the Home Assistant config

That might be true and perhaps still works.

However I am using Google Home app on iOS. Been trying to spin up an Android VM and then use an older version of apk, but having issues with getting the VM up and running.

Will keep trying…

@hp-sn Im not sure I agree that this doesn’t work. Im in Australia, and have recently purchased a Google Home. I am running the latest Home app and I have done the above twice now and it worked no problems. This was not possible trying to use the Google Assistant on phone only but works fine with the Home. Ive never had a physical hue device.

Edit: I am using Android s7, so it looks like iOS app could be the problem

@andrewpc I am seeing mixed messages re Google Home app on Android also. See the thread I linked to.

I am trying to run up a android VM on KVM/vSphere to see if I can get around that way. Will report back.


So, I was able to follow the instructions here and link Google Home app on Android to emulated_hue running with hassio.

I used the version of Google Home app recommended in the above instructions.

Once I was able to complete the linking, all the devices appeared in Google Home app on iOS and I am now able to control my devices via Google Home.

@hp-sn Is it still working for you?

@Norik_Krasniqi I have stopped using emulated_hue and moved to Google Assistant component. Works great.

Check out

Since my ISP does not let me do port forwarding I went with Tor Oninon Configuration ( Since this in reality has end to end encryption do I need to a SSL Certificate in order to have this work with google home?

Any help would be much appreciated.

@Norik_Krasniqi The two primary requirements for the Google Assistant component is that your Home Assistant is available publicly over the internet. This is because Google will make calls to Home Assistant API to fulfil what you have requested from the assistant.

The API (HTTP port) needs to be available over SSL with a certificate that is signed by a Trusted public CA. If you dont want to buy a SSL cert, or if you have a dynamic IP, you could look at Duck DNS.

There is a lot of information in the following thread:

@hp-sn I already know about this one but the issue is that my ISP limits me because they let port forwarding only for commercial customers while not for residential. I have tried to forward the port 8123 but when I try to access from outside http://publicIP:8123, I have no access.

Since at this time with this ISP this is not an option, do you think there is any other way?

You could try Tor, though I’m unsure how well it’ll work for this.

@Tinkerer I did and it’s working but now I want to integrate Google Home but Google Home requires SSL. Can i add SSL to Tor? If yes, any advise how to do that?

@Norik_Krasniqi The primary issue for you is not if you have the communication between Google Cloud and your HASS encrypted or not. The issue is that your HASS needs to be publicly available for Google Cloud to make API calls.

ToR endpoints cannot be routed to by Google Cloud (This is where your app will run).

So if your ISP does not allow any incoming traffic (on any port) then you do not have any options. I would suggest to change to another ISP, or check if the ISP will allow incoming traffic on ANY port. It doesnt need to be TCP/8123. It can be anything.

Once you have solved that, then you can look at encrypting the communication with SSL using DuckDNS or a “real” certificate.