Google home no longer able to control lamps and switches

Nabu Casa integration with my google home and my google nest mini has worked fine for years, but suddenly most entities do not work.

I can say “hey google, what is the temperature in the living room”, which returns the correct data from the sensor.
But “hey google, turn on lamp” does nothing, and “hey google turn off lamp” returns a not understood reply.

Integration with google home seems to be working fine, since the entities are exposed and shown, and when I click the entity in google home app, eg lamp, it turns on and off as expected.

If I look in the log in google home, all commands, including turn on lamp, are shown, no errors, simply just no action after the command.

I am baffled to what causes this…
Is it google home or home assistant that fails?

1 Like

For me it works in English, but not in french. It did work a few days ago.
Looks like a Google assistant issue for other languages.

Edit: After more investigation, only some french commands do not work. “Ouvre la lumière du salon” (turn on salon light) does not work, but “règle la lumière du salon à 100%” (adjust salon light to 100%) does work. Even with 0%.

Tried removing and adding french language, same result.


Exactly the same here, using Danish.
I can get temperature from a sensor, and I can turn on a lamp by (in Danish) saying ‘set lamp to x percentage’, but not by saying ‘turn on lamp’.
And if I say ‘turn off lamp’ nest responds with sorry I do not understand, if I say ‘turn on lamp’ nothing happens - no response at all.

Haven’t tried in English.

Very strange bug.

Similar (but not identical) here: Why would Google Assistant complain about a specific device not being available?

The locale is French

Could you try the following:

In Google home app, go to settings, all settings, languages

Remove all languages, and re-add only “native” language - not dual languages…

Test if you can now control all entities.

If so, you can add a second language if needed.

It works for me.

1 Like

Thanks! It works now :grinning:. Having native language first and then English, it works.

If I put back English as first, then I get the same issue again.

Nice to have a workaround!