Google Home - Not able to connect to/sync with Nabu Casa

I’m currently running Hassio 0.109.6 on a Raspberry Pi 3b+. So far, everything seems to be running smoothly. I’ve bought a subscription to an account at Nabu Casa and enabled the options for Remote Control and Google Assistant (including state reporting).

I want to connect Home Assistant with my Google Home, but I’m running into a problem. When I’m adding “Home Assistant Cloud by Nabu Casa” as a device I’m getting 2 messages:

  1. Home Assistant Cloud by Nabu Casa is linked
  2. Something went wrong. Try again.

The result is that my Home Assistant devices/entities/rooms are not showing up in Google Home.

What I’ve done so far:

  1. Reset my Google Home to factory settings (pressing the mute button for 15 secs)
  2. Setting up my Google Home
  3. Rebooted my Raspberry Pi
  4. Checked if I can connect to Home Assistant by Nabu Casa remote control
  5. Tried to add device"HA Cloud by Nabu Casa" to Google Home

But these steps don’t provide me with the desired result. Anyone some thoughts?

You could try to force to sync by the voice command:

Hey Google sync all devices

Hi Mattias,

I just give that try, but didn’t work. The issue is that although I get the message that HA Cloud is linked, no devices show up.

Sorry it didn’t help.

Then I don’t have any more suggestion than to try go into configuration-> Home Assistant Cloud
And try to turn off and then on the google home integration.
Maybe try tomorrow. Sometimes google is slow to sync.

Double check if you press “Manage Entities” that there are some devices that is exported.

Sorry I don’t have any more suggestion.

Well, your comment on press “Manage Entities” inspired me and with that, I found a solution. So thanks for your help.

My solution is the following:

  1. [HA Assistant Cloud][Google Assitant][Manage Entities] I unexposed all my (current) 75 entities.
  2. [HA Assistant Cloud][Google Assitant]. I pressed the “Activate the Home Assistant skill for Google Assistant” and pressed the “unlink”-button (unlinking my Nabu Casa account from Google).
  3. In the Google Home app on my iPhone, I added the “HA Cloud by Nabu Casa”- device and was asked for my login credentials. This linked my Nabu Casa account again to Google.
  4. [HA Assistant Cloud][Google Assitant][Manage Entities]Expose my entities one-by-one at a time seems to work. If I select multiple entities, it doesn’t work (don’t know why yet)
3 Likes

I was running into the same issue as Egon. I am running 0.109.2 on a Hyper-V VM. I started adding my devices one by one as suggested by Egon as a solution. In the process of doing that, I determined two of my devices, two zwave Inovelli LZW42 Multi-Color Bulbs, would cause the google sync process to fail. As long as I didn’t expose those two bulbs to Nabu Casa / Google, Google would be able to see and sync all my lights and switches.

@Egon, did you or could you determine if there was a specific device that was causing your syncs to fail?

@kahnman yes I’ve noticed the same. 2 light groups setup in Home Assistant can’t be added.

The 2 groups contain multiple hue bulbs, a zigbee led strip and 4 tradfri g10 bulbs. Not sure yet which of these is causing the problem!

Add: Just took a look and noticed that the 2 signee led strips are causing the issue. All Hue, Tradfri, and home assistant light groups (that don’t contain the zigbee lights) can be exposed without an issue to Google.

I’m curious why zWave and Zigbee lights cause this problem?

I have tried everything listed here multiple times with no positive results. I am not able to connect Nabu Casa to Google Home. Among other things I have tried to unexpose all entities in Nabu Casa configuration. Nabu Casa works perfectly with Alexa, but unfortunately it doesn’t with Google Home. I have checked similar topics on this forum and other forums but to no avail. Please somebody help. Thank you!

After many hours of trying to solve this including contacting Nabu Casa support it seems I have finally found the solution. Though the solution appears to be quite random.

Out of desperation I started to toggle domains in “manage domains” pop-up menu one by one. When I enabled only “Script Domain” it suddenly started working.

I also had this problem, turned off all the domains, no change – enabled only a single switch, no change. Tried a bunch of times to link. Tried ‘unlinking’ in the Google webpage (the one that says “hass.io”) in between, no change – unlink seemed to be acknowledged by the web page, and then I’d go into Home app, which didn’t show HA linked, attempt to link Nabu Casa (go through oauth-style granting flow), would return to the list with no error, but it wouldn’t move up to the top in the ‘linked’ section (but if I reloaded the webpage, it would then get the “Unlink” action, so something was happening in the Google backend). I tried clearing the Home app’s cache, and storage, and uninstalling/reinstalling… no change. Probably 45 minutes later, the home app started displaying a button similar to “Link Home Assistant” at the top. Tapping that led to the same flow, and it… still not working. I gave up for the night.

This morning, I tried it again starting at the button prompt, and boom, it worked fine, and my switch showed up. Not sure what magically fixed itself, but I’m happy it’s finally resolved. Maybe Google Home app needed to do some additional ‘discovery’ on my local network? No idea.

I haven’t dared try to expose additional items to the integration yet, but will do so today. Hopefully I can get them all synced – really glad to finally rid myself of SmartThings (although contemplating keeping it around solely to talk to my Samsung refrigerator… sigh.)

It seems that you massively increase your chances of solving this issue by having Nginx Proxy Manager add-on setup properly according to the instructions posted here. (“Domain names” could be your nabu casa web address, or e.g. your duckdns address, or whatever address you use to connect to your HA remotely.)

This worked for me as well when i was having invalid user id/pass when trying to update devices in google home app.

  1. [HA Assistant Cloud][Google Assitant][Manage Entities] I unexposed all my (current) 75 entities.
  2. [HA Assistant Cloud][Google Assitant]. I pressed the “Activate the Home Assistant skill for Google Assistant” and pressed the “unlink”-button (unlinking my Nabu Casa account from Google).
  3. In the Google Home app on my iPhone, I added the “HA Cloud by Nabu Casa”- device and was asked for my login credentials. This linked my Nabu Casa account again to Google.
  4. [HA Assistant Cloud][Google Assitant][Manage Entities]Expose my entities one-by-one at a time seems to work. If I select multiple entities, it doesn’t work (don’t know why yet)