Google-Nest Offical Device Access Console Finally Released!

This works for me, no quotes

client_id: !secret nest-client-id
client_secret: !secret nest-client-secret
project_id: !secret nest-project-id
subscriber_id: !secret nest-subscriber-id

No quotes in secrets file either.

Hello, where is the place to auth my public ip ? OAUTH return URIs list, with google

I’ve proposed a change with your suggestion so the next release has the documentation for the two APIs pulled apart:

1 Like

Do you have the latest version of Home Assistant installed? The new Nest integration only came out in 0.117. I received this error when I had 0.116 installed and upgrading HA resolved this for me., Credentials, OAuth 2.0 Client IDs, your client ID for Web application, Authorized Redirect URIs. You should have and

I’m not exactly sure how to do this in IIS as I use an Apache reverse proxy for my HA deployment, but I was having a somewhat similar issue trying to set this up. I kept getting the “aborted” error message in the UI regardless of whether or where my URLs were configured. I ended up having to follow the last post in this thread (Reverse Proxy with Apache) to configure my Apache server. The major changes seemed to be related to passing the external IP of the source to the HA instance in the form of a header. I’m sure there’s a comparable configuration in IIS you could play around with.

This is much much better. Thanks for the work. In addition, on this section:

Additionally, Home Assistant must be configured with a URL (e.g., external exposed http , Nabu Casa, etc). When setting up the OAuth credentials, make sure the Home Assistant URL is in the list of Authorized redirect URIs , so the redirect back to Home Assistant can get an OAuth authorization code.

I think you have to indicate an example of the complete oauth URI and indicate that this have to be done before you start the integration part on hass, otherwise you will be in a trouble and the onyl way to achieve the integration is to recreate de secret_id and start again.

@allenporter How do I get your latest PRs into my HA before HA releases them?
Currently running HA 0.117.2 …

oook, now i get it. That part would be:

  1. Go to GCP, Pub/Sub, Subscriptions: Create a subscription with following data:
  • ID: enter what you want (this ID will be added to HA configuration.yaml)
  • Pub/Sub topic: Enter manually, and add the one from device access project
  • Mode= Pull
  • Retention=45min

would be right?

and… do we need to maintain the external public URL towards our HS? or it was just for the first OAUTH sync? i would not like to have this opened to internet always :frowning:

My sub retention is set to 7 day and my :8123 is always open to internet so I have remote access to HA via my app. I’m not sure if the OAuth 2.0 URI’s need to always be listed but I expect they would. I understand your concerns though…

Ok, followed now the last part of the guide and now its ok:

The thing is that my HA only gets Nest temp and humidity when i restart it, one time… it doesnt get a continuous value :(… still investigating

The retention time was set to 45min because I have read “below 1h” in PR 15512: Note the message retention is how long messages will queue while offline, so keep that short (e.g., under an hour) to avoid a potentially large backlog of updates.

I tried with both formats and didn’t work for me… I still having the issue

Error 400: redirect_uri_mismatch

The redirect URI in the request,, does not match the ones authorized for the OAuth client. To update the authorized redirect URIs, visit:${your_client_id}?project=${your_project_number}

¿Did you defined that URL on the home assistant external URL?

are you sure your HA supports SSL? try with http instead of https in the URI field

I have Https with duckdns working from many time.
I configured http and https in console, and not working neither


1 Like

Do you have configured under ??

I include it, but… not works…{your_project_id}/information…

Feel free to try out the appsdaemon app I wrote to interface the NEST thermostats using this API with HASS.


I tried adding new custom repository dbecknel/appdaemon to HACS but I received this error: Repostitory structure for main is not compliant