Google TTS Not Working Correctly

I have a problem with Google TTS (google_say service) which is best described with an example - “Hello people” is spoken as “Hello percent 20 people”. If I try the same thing with the cloud_say service then the words are spoken correctly but I hate the voice which is very robotic (I don’t really understand where the cloud_say service actually comes from or how it is enabled in my config).

My setup is Home Assistant Core version 0.113.2 on Synology Docker and my config is shown below which had been working well for over a year:

  - platform: google_translate
    service_name: google_say
    cache: true
    cache_dir: /config/tts
    time_memory: 28800
    language: 'en-uk'

I have tried restarting HA, restarting the Docker container, and clearing the cache however the problem remains.

Although the problem appears to have started around the time I upgraded to version 0.113.2 I think it is more likely related to the fact that I was experimenting with the Synology Community package which allows you to run full Home Assisant with Supervior and Add-ons. However I currently have this and its associated containers disabled as I have reverted back to HA Core for the time being which is all running fine except for this TTS issue.

1 Like

It’s a bug introduced in 0.113.2. There are other posts here that have reported the behavior and it has been posted as an Issue in the core repo on GitHub.

OK understood, thanks for the prompt response.

I have the same. To fix it just remove the spaces. say if you had The alarm has been disarmed change it to thealarmhasbeendisarmed works ok for now.

Same problem. But removing space cause a pronunce not correctly without pauses

If you have the same problem, follow the same issue.See post 2 above.

works ok to me, I use it to anounce the alarm and I change the “The alarm is set to arm home” to “Thealarmissettoarmhome” it its almost identical to before. tri without any capitals.

We know that.

Not working, sometimes it works, sometimes it doesn´t. Any idea how to fix it?
The same thing with TTS_cloud_say service.

check your configuration.yaml. Note that the language for google tts should be in 2 character language code. For us in Australia, it used to work in en-au but now it needs to be just en

Everything works flawlessly now. Thanks