Service tts.google_translate_say is translating spaces to %20

    service: tts.google_translate_say
    entity_id: media_player.theatre_room_home
      message: "hello there this is a test"

I have the above config in my automations.yaml. But when my google home mini turns on it works somewhat as it pronounces every space as “percent 20”. It reads… hello percent 20 there is percent 20 is percent 20 a percent 20 test.

What is weird is when i do the speak feature through the media player card it works fine.

Any idea how i could fix this? Thank you.


Quotes around the message?

I tried " and ’ still same issue.

Just had the same thing happen in my system. I just updated to 0.113.2 but it could be a Google issue.

I had the same issue, I didn’t have this prior to the update, but I can’t recall the version I updated from :frowning:

Same issue since v0.113.2 update. Worked fine in 1.113.1.

Doesn’t seem to like spaces in the tts message.

OK well I might skip this one for now, I use Google TTS a lot.

Happening here as well right after updating to 0.113.2.

There’s a bug report on the core repo for it.


Yep, I have this issue as well after updating

Same issue.

Yep. Same issue here also.

Yes, Same problem here

Yes, same problem here…

Yep, me too.

Same issue since v0.113.2 update.

Im also having this problem.

and here: 0.113: Automations & Scripts, and even more performance!

widespread indeed, no response yet, so we’ll have to sit this out for now (or downgrade )

1 Like

And lose those fantastic scripting improvements? :scream:

only a small step to 113.1 for the time being :wink: still great scripting there

I don’t think that’s likely.
Klogg is already pushing the 0.113.2 scripting environment !