HA & Ikea Tradfri: Timeout validating the code

Hi all

Today I wanted to integrate Ikea Tradfri into HA. It discovered it by itself, but when inserting the security code I got from the back of the gateway (also checked with QR), it gives me the message: “Timeout Validating the Code”.

Can anyone enlighten me on a solution?

Same problem for me :frowning: .

I’m having the same issue. IKEA Tradfri integration was working perfectly, but since two days ago the devices could not be found. I removed the integration and added it again, resulting in the security key time-out error.

I tried to restore a back-up of 2 weeks ago, and then the devices worked for a few minutes, after which they stopped working again. Restored to the most recent back-up again and still having the same issues.

Does anybody know how to fix this? Thanks!

simular problem here

image

Just as a side note, I do have a HUE bridge as well. Is it conflicting because it is also a light source bridge like the trådfri bridge?

After a firmware update of tradfri it is now working again. Seems like the issue was at tradfri!

Can you elaborate on which version you were?
I’m on latest SW 1.10.43 and it’s still not working.

Not working.

My tradfri firmware is version 1.11.7

Strange, I have a lower version than you, but it says it’s up to date…

same for me also 43, still not working

1 Like

I found the problem.
In the /config/.storage/core.config_entries was still a part pointing to the (deleted) Tradfri integration.
I did delete this, restarted home assistant and everything as ok.

Nothing in that file for my case.
Not fixed for me.

Home Assistant was updated to 0.115.3
Tradfri Gateway was updated to 1.11.47

Stuff still does not work. Still getting the timeout.

Same happening here, it stopped working from the one moment to the next.
I’m on Gateway version 1.11.47

Has anyone found what is going on in the meantime?

Same here, since the 1.14.1 Gateway release (on 0.116.4). Nobbled HomeKit and the Tradfri integration. Initially just reloading the integration worked. Then it stopped, and didn’t give the option. Eventually finds it automatically, but just times out.

Edit: Tried adding the integration again manually (with IP, despite the auto-discovery)… and it came back. Not confident it’ll stay… but working for now.