HA is not accessible after "failed to start wait until kernel time synchronized" error

Hello all. I started working with HA after the Insteon shutdown. Thanks to getting help here on the forums and HA upgrades for Insteon, I had it working well. This morning I allowed the latest update to install and now I am unable to access the HA log in screen in a browser. I restarted HA and watched the progress. There is an error saying “failed to start wait until kernel time synchronized” and instructions to “See ‘systemctl status systemd-time-wait-sync.service’ for details.” I tried typing that into the command line but it’s not recognized. Sadly, due to my inexperience I failed to take any snapshots of my VM. I’m running virtual box on a Windows 10 laptop. I was able to connect to HA before the installation of the update.

I read some of the previous posts on this error. Some people report hardware issues like wifi connection and a bad SD card having something to do with the failed to start error but I don’t have an SD card in this machine and everything else seems to be working fine.

Any suggestions would be appreciated.


Update 1. I followed the cli command instructions below from callumw in this post:
nmcli connection show
nmcli con edit “Home Assistant OS default” # or whatever your HA instance is called

After that I was able to access the HA UI in the browser. Then I tried to follow the instructions for checking Settings | System | Network, but found that most of the options under System are unavailable. The exceptions are Backups, Analytics, and Storage. The others return an error stating “Error while loading page system_health” or other page name. I also get that same error when clicking my user name at the bottom of the HA vertical nav pane.

Searching in Settings for Restart I was able to click to restart the server but nothing changed.

Trying to figure out what to do next.

Update 2: I was able restore a backup, reverting to HA Core 2022.5.4. That allowed me to get into the network and other settings that were not working. As described in the other post I referenced, the IPv4 setting was disabled. I changed it to DHCP but I’m not sure if it took because there was an error message saying to check the supervisor log. I don’t know how to get to that as it doesn’t seem to be under the Logbook menu option. I ran an HA backup and took a snapshot of the VM in Virtual Box. Remote access is working again. HA is prompting to update to Core version 6.5.

Update 3: I powered down the VM and restarted it. It started successfully with no “failed to start wait until kernel time” error. I allowed HA to update to 6.5. Everything seems to be working correctly. The network interface setting is on DHCP. I powered off the VM and restarted it. There were no startup errors. IPv4 is still set to DHCP. Remote access is working. Everything seems to be working correctly again.


p.s. Check out these files for some logging:
They should be in the same location as your configuration.yaml

Thanks, but I don’t know how to get to the location of these files. I’ve stayed away from yaml. Manually editing code or commands is something I’d like to avoid. Thanks for those instructions in your other post! They saved me from starting over, again.