HA keep crashing after few days


#1

Hey there I am using HASSIO 0.80.3
changed from HASSBIAN,
ping is working only server is down.
every few days server stops working and need restart by plug out all connections,

anyone seen this issue ?
any solution ?


#2

Raspberry Pi?
If yes, SD Card may be failing.


#3

it should cause constant failures no?


#4

No…it may work short period then fail.

I think I remember ping resulting in OK but ssh fail. All ok again upon reboot the fail again after a day or two.

Ha database was writing a lot of data and killing my SD cards. I turned it off then later moved database to MySQL+Server+HDD


#5

now also after reboot cannot work properly…


#6

I had changed the SD card to new one…
Server keeps crushing after few days…
i also tried to upgrade to 0.82 and it stuck in loop and require restart…


#7

Power supply?

You have many component configured?
Is DB filling up and taking all space on SD card?


#8

79 components

Data base 50mb
Text file 10mb…
Power supply 60W…


#9

60watt? what hardware?

what is install method?


#10

HASSIO…

using modbus relays…


#11

Any other idea?
i had changed to Hassbian and getting same result…

changed also from pi 3 to pi 3+


#12

Try fresh default and see result.
Then slowly add component.

If not hardware it could be some component casuimg issue. This would likely show in a log somewhere.

I had same issuenof restart after 1 day or 2. This was actually caused by separate docker container eating up resources resulting in ha crash due to out of memory.


#13

already tried …
could not find any issue so far…

i must say i have mostly modbus components , few camera’s

i had changed the Pi to 3 B+

New memory card ( so i guess this is not memory issue).

I have limited the recorder to delete files every few min.

I must say in such case PI web terminal is working but HA not working

After reboot comes back to life.

what is the best way to analyze this?


#14

Hey added system log how can i read it?


#15

Sorry. I don’t use hassbian so I am not familiar with file locations.

Have you tried default install?


#16

Hassio…?
Yes changed due to same issues…
only Hassio crash totally , here i can restart service…

how can i make trigger to restart service in case of failure?


#17

anyone? any good news?


#18

You can run bash or python script to check service and restart if not available.

Honestly this seem like hardware issue. There is no issue that will result in default install crash after several days.


#19

I change the SD card, changed the Pi , so i think not likely to be HW issue…

How to run this script ?

can you please advise for some more information ?