HA not picking up changes done through a Vera controller

I’ve had Home Assistant running for a quite a few months now. I’m currently running version 95.4. I use a Vera controller to handle my z-wave devices and I’ve integrated that into HA when I first set it up. I still have a few scenes and automations I haven’t converted over yet plus some remote devices that send direct commands to Vera. I’ve noticed recently that when something gets turned on or off through Vera, the changes don’t get carried over to HA. I’m pretty sure they used to or am I wrong about that? Of course if I reboot HA, the changes show up, but does it poll Vera at some interval to check for changes?

I reported on this page, so please post your comment there so the issue can be fixed. thank you

Still not working in 96.4

Anyone know if this has been addressed yet? I’m a big fan of H/A but stuck in version 94.4 until this get resolved.

I’m running 96.5 and it still hasn’t been fixed.

Just saw this in the 0.98 release notes here: https://www.home-assistant.io/blog/2019/08/28/release-98/

* Update pyvera to 0.3.4 ([@KptnKMan](https://github.com/KptnKMan) - [#25986](https://github.com/home-assistant/home-assistant/pull/25986)) ([vera docs](https://www.home-assistant.io/components/vera/))

Has anyone upgraded to .98 yet that can confirm that these changes do really bring back sensor updates. I have a very large configuration and am wary of making significant changes if the component is still broken.
Hopefully somebody can confirm this soon. There have been many breaking changes since 0.94.4, the last stable version where Vera sensors still worked, and I’m assuming I will have some work to do to get back to smooth operations.

I just saw .98 is available because of your post :smile: My sensors seemed to have been working in the last release I upgraded to (97.2), but it still wasn’t recognizing switches that were activated through Vera. I’ll upgrade to .98 soon and see if it fixes it once and for all.