Vera Plus Z-wave Hub stops updating home assistant with sensors status

This happened after updating hassio to 0.95. After removing the vera component from configuration.yaml restarting home assistant then adding it back, the hub would work fine and all the sensors would show in home assistant and their status would update all the time. but then after couple of hours the sensors would stop updating in home assistant and it just idles. the sensors are working fine in the vera UI but not in home assistant.

any help with this will be much appreciated.

Thank you

4 Likes

I’m having the same issue in 0.95 my install has been quite crippled by this. I have raised an issue on GitHub please add any more information you might have to help those capable diagnose.

+1 Same issue 0.95.4

After re-starting Hassio, a couple of hours later motion sensors (Philio, Neo Coolcam, D-Link) stop updating event in Hassio. All automations based on them stop working. They are still reporting events at Vera Lite unit though.

I set the Vera component in debug logging and it shows normal polling activity until eventually it stops reporting and polling. It just stops reporting polling activity :frowning: Last lines in the logs are

2019-07-07 11:15:00 DEBUG (Vera Poll Thread) [pyvera] get_changed_devices() requesting payload {‘timeout’: 30, ‘minimumdelay’: 200, ‘id’: ‘lu_sdata’, ‘loadtime’: 1562385868, ‘dataversion’: 385901882}
2019-07-07 11:15:30 DEBUG (Vera Poll Thread) [pyvera.subscribe] Poll returned

Look as if HA gets a timeout when waiting for Vera to reply, it won’t continue polling. Is this the case? Is this the expected behaviour? If so, could it be tweaked by adjusting timeout, or not stopping polling even if a timeout is eventually got?

I’m having the same issues with my motion sensors. My switches work fine.

I was referred to this thread from here HA not picking up changes done through a Vera controller. None of my Vera components appear to be updating in HA including switches and lights. Also seems to have happened after updating to 95.x. I have a few automation devices that I haven’t converted to HA yet, so they still call Vera directly to turn on/off stuff. Those changes used to show up in HA but don’t anymore.

thanks for referring me to this…trying it now.

EDIT: it did work. removing the component, restarting, then adding the component back in, and a restart appeared to fix it. binary sensors are updating and my motion sensors are working. thanks for the assist!

EDIT2: stopped working again.

is it still working after you did that? because mine stopped after a while

Yeah. You’re right. It stopped working last night. Will edit my post.

Backed out to 0.94.4, problem affected almost all automation in relation to Vera devices, including security devices. In other words a crippling bug.

I’m considering backing out to 94.4 as well however I finally got spotcast working on 95. I’m really hoping for an update.

I rolled back to 94.4 and am waiting for a solution.

An option might be to take the integration from 94.4 and make it into a custom component in 95. Not sure if it is that easy.

Upgrade to the beta version and came to normal

1 Like

Any word on .96? I rolled back to 0.94.4 but I’m hesitant to upgrade again if it is still broken.

96.4 is still broken. Just updated last night hoping it would fix it, but still no-go.

Work ok 12h after a restart, then stop update the sensors.

0.96.5 also broken for me

So .97 is out and still no fix for Vera integration? What does one need to do to get this working again?

FWIW, I just updated to 0.97.2 because I noted that it updated to pyvera 0.3.3, which was supposed to fix this problem, but the Vera status still doesn’t update. EDIT: just submitted a bug report to reopen this issue.

The same problem - updated to 0.97.2, Vera integration does not work.

It was working fine for me after I updated to 0.96 but then it stopped again after I updated to 0.97. How is that even possible ???