HA OS - Need help mounting external media or gaining root access - I've tried everything 😬

I got my Yellow in the mail last month and was excited to migrate over from my Docker NAS installation. Everything went fine except that I really miss my external media. It was easy to mount my media volume into the container in my old installation, but I’m having a hell of a time getting more space attached to my Yellow.

First I tried every permutation of these instructions [1] for SMB mounting and I get this error no matter what I try, even though I could browse the share just fine using the File Browser addon [2] which rules out credential and network issues I think:

Error running command: `mkdir -p /media/synology;mount -t cifs -o vers=3.0,noserverinfo,user=marquismarc,password=[redacted],domain=WORKGROUP,sec=nltm //192.168.0.100/Media /media/audio`, return code: 111`

I wanted to run this via SSH to shorten the feedback cycle (rather than rebooting to load the config each time I wanted to try). I kept getting “Permission Denied” errors, which I presume is because the Docker container doesn’t have some system-level permissions for mounting.

Soo, I tried to follow the instructions to get root access to the Yellow, but putting my authorized_keys on a FAT-formatted USB-stick named CONFIG has no effect and I get Connection refused when trying to SSH to port 22222:

I also threw up the white flag and decided to use my USB stick as a media directory, discovered it wasn’t plug-n-play, attempted these popular udev mount config instructions, but I think the Yellow just isn’t recognizing my USB stick or something - I can’t really verify whether or not the udev rule is placed in /etc/udev without root access (see above), but I can verify that another USB stick containing media doesn’t appear anywhere in /mnt after being plugged in.

I’m out of patience with this problem. Yellow was supposed to be an upgrade for me and make my life easier but the supervised OS design is more of a roadblock than it is helpful. Can I get some assistance from y’all?

  • some acknowledgment that this is way more frustrating than it needs to be :stuck_out_tongue:
  • advice on what the next steps should be - maybe how to debug whether or not my USB port on my Yellow is functional?

I wanted to be thorough and link to forum posts I’d already tried, but new users are only allowed to put 2 links in their posts. Here’s 1 and 2.

I have since tried formatting the drive as exFAT using an old Windows 7 laptop I have lying around, but found no change to the Connection refused error.

Dang, I was hoping it would be something simple and obvious I’d missed. Giving this a bump in the hopes that someone new stumbles across this post with a suggestion or two :pray:

Welcome to the forums.
Does this post help?

Just curious, what do you want the external disk for?
Also, how does the Supervisor limit you? I have been running the native x86 HAOS forever and I would really miss the supervisor.

Thanks!

Does this post help?

I can give that add-on a shot, but I think it’s meant for exposing your Home-Assistant disk as a Samba server so that you can access it elsewhere on the network instead of the opposite which I want (accessing Samba servers already present on the network within HA and referring to the files in media_player.play_media calls)

what do you want the external disk for?

I’ve got a bunch of automations that play sound effects or audio tracks, enough that the SD card on the RPi would limit me. I know there’s mixed opinions on whether HA should behave as a fully-featured media server and most of my music is on Spotify, but I’ve got some tracks as MP3s and HA makes it really easy to cast them to the speakers in my home!

how does the Supervisor limit you?

If I had root access to the Supervisor (I might be mixing up terminology; I’m referring to whatever execution environment hosts the Docker containers), I’d be able to troubleshoot the SMB mounts and I’d also be able to put the udev rule in place myself without relying on this weird CONFIG USB drive convention. I know in an ideal world we wouldn’t need root access to run and maintain HA - I don’t bother rooting my phone, for example - but for my use case (which really isn’t that exotic IMHO) it would be a heck of a lot easier :innocent:

1 Like

There’s a lot of threads (including feature requests) about this topic already (for example). I’ve tried a few of the ‘solutions’ to no avail.

1 Like

I’ve successfully opened port 22222 for root access using this add-on when I was looking for an easier way to set HA to use my local NTP server. I was using a RPi 4 with HassOS, so this probably will work just the same in a Yellow.
The add-on is basically adding an SSH key to your OS so you can use that key for remote logon.

1 Like

For ssh, try using the addon above. Also try generating some new SSH keys. Old ones dont always work.

For mounting, you may be interested in my other addon which will run commands at startup in the context of a container. ✔️🏃Run On Startup.d

1 Like