[New Addon] Samba NAS. (Mount external disk and share it )

Tags: #<Tag:0x00007f7399511df0>

Hi to all,
I wish to share my last mod of the official samba addon. It is based on the last version (9.0) and allow to mount external ( USB,SD etc ) disk by partition label and share via samba.

It is a complete plugin replacement of the original ( same config works too ) plus some features:

  • Support to automount and autoshare disk by label ( Protection Mode must be turned off )
  • Support to expose Time Machine compatible devices ( you can use any share as TimeMachine target!)
  • Add mDNS for ZeroConf and Bonjour network.

To use add my addon repository: https://github.com/dianlight/hassio-addons

17 Likes

Hi, could you please add support for compatibility mode which based on v9.2? Thanks.

Done. The new version 9.0.2-nas is available.

Just installed today - it’s working perfectly! Thanks so much for this - exactly what the ‘Official’ Samba add-on was missing!!

Terry

1 Like

Thanks a ton, this is one of the best addon I had, it’s automount feature is the one i’m looking for.
Many thanks for great addon.

Btw, I have a newbie question, how do i know where is the usb mounted location path?
I installed aria2 as downloader machine, and want to save the downloaded files to external usb drive (the one that mounted via this addon). and access it from outside via samba protocol.

This addon mount and share the disks via samba. You can’t access to mount path in another docker so you need to remount from the network like my version of Plex addon do.
If the aria docker is unable to mount cifs network drivers you can’t use the exposed disk.

L

thanks for info. since i installed aria2 outside docker, so i have to mount the external disk manually to use it as aria download path. and share it via this addon.

Does the addon support mounting for external ntfs drives?

On hassios 3.x yes on 4.x it seems that for all platforms there is not the necessary “fuse” module in the kernel.

In any case, it is strongly discouraged. Exposing a fuse fs via samba is very slow (5 to 6 times compared to a native fs) because samba must read and write synchronously on the device and no ACL support.

The best of is use ext4.

L.

Ciao,

Just a noob question: How can I use this adding to mount in HA a folder on my Unraid Nas?

This is what I want to achieve:
Use nas share to store videos of motioneye addon against of the hassio share.

you can’t.
This addon mount can mount the NAS and share via samba. To mount the disk on motioneye addon you need modify the addon to support the mount of samba disk. Like I have done with plex addon.

L.

well, ty for your feedback. I think the only solution is to switch to a regular motioneye container directly inside the NAS and then expose only the cam to HA.

Hey guys, I am trying to make this work on my Hass.io install.
I am running on a raspberry pi 3+.

This might be a stupid question, but I can’t figure out how to get my disk label from the disk I want to mount.
I have a hard drive connected to the pi via usb. It’s formatted to FAT32.
However as I said I don’t know how to figure out the label to put in the config, so it won’t mount the drive.

Any chance someone can help me with it?

Cheers!

1 Like

Hi @jlnbln

I’m pretty new to this too, but I’m also running HA on a Raspberry Pi and have just set up this addon to access an attached usb drive. I actually formatted my drive to ext4 as I know this works well with linux and is generally a much better file system than FAT32. I did this with the free version of Partition Wizard in windows (partitionwizard.com) and gave it a label as part of the formatting process. I then simply added that label name in the config and restarted the add-on.

I’m not sure if a FAT32 formatted drive will work, but I presume if you plug the drive into windows you will be able to see the drive label in windows explorer as the name of the drive and then try that in the HA config in your Pi?

Also, @Lucio_Tarantino many thanks for this addon and also your ‘Plex with Nas’ addon. I’m using both together and they are working well!

Thank you for for this addon. This is the most important missing feature of hassio from hassbian.

I installed your addon, add mounting point in fstab:
//192.168.1.1/datacenter /mnt/datacenter cifs user=admin,password=xxxxxx,vers=1.0,rw 0 0

But I still get errors in hassio:

etc $ mount -a
mount: mounting //192.168.1.1/datacenter on /mnt/datacenter failed: Permission denied

With the new Media Browser feature in the 0.115 release does anyone know how to add a folder from a mounted external disk which is using this Addon to make it available as a media source in HA? https://www.home-assistant.io/integrations/media_source/

I know that the core Samba addon that ‘Samba NAS’ is based on has been updated to 9.3 so perhaps when/if Samba NAS updated that would help?

Hi,
Is there a way I can bring the “media” folder back? The folder seems to disappear every time I run the Samba NAS. But if I stop it from running then run the Samba Share again, the media folder magically comes back. :slight_smile:

Hi @Lucio_Tarantino,
Thx for the addons (samba and plex), these are very nice.
I would like to ask when you will update the plex in the plex addon?

I am currently working on a PR for The operating-system to allow the discs to be mounted directly from the homeassistant by solving the problem at the root. It is not yet stable and it is not recognised that it will be accepted.

If I can’t release the PR by the week, I’ll update the two addons. In any case, I don’t expect to add functionality such as medium_source support.

stay tuned!

L

2 Likes