I was checking on other system to update my HA OS RPi3 installation.
I’d like to stick with device with a supported HA OS image.
I noticed that in the list of images there is these devices from ODROID

Odroid-C2, Odroid-C4, Odroid-N2, Odroid-XU4

but on the ODROID website I see the ODROID-N2+ with 4GB of ram.
Do you know if this “+” version is supported?
Does anyone have any experience with it?


I’m also trying to find out if the ODROID-N2+ is a suitable HassOS box, especially in comparison to the Intel NUC.

I understand it is about 2x about as fast as a Pi4.


Thanks, but I read that press release yesterday.
That lists specs, but doesn’t talk about experience.

I’m referring to the published performance benchmarks of the ODROID-N2+ compared to the Pi4, for example:

Has anyone used an ODROID-N2+, and can speak for its experience?
I ask because most NUCs are not much more expensive, and seem to be much more powerful.

A complete ODROID-N2+ setup seems to be in the ~150 EUR range, but a an example Celeron/i3 NUC is in the ~200-250+ EUR range.

@plonka2000 I was checking the ODROID-N2+ for the same reason as you did, but I was also trying to consider the performance in running other containers thanks to the Home Assistant OS infrastructure, like Plex, Pihole or others, so I can merge different system that I have now around the house into one.

Regarding Plex, I read something around the web that Plex is not able to leverage GPU performance from an SBC like ODROID, but it can in a Nuc system.

Do you have any thoughts or info about it?

After the announcement that the ODROID N2+ was the future of HA, I was surprised there is so little said about it by the main developers. I am also not happy about the shipping cost at Hardkernel. I did not know the eMMC used was proprietary. So the 128GB is $45 with $33 shipping?? must be do to the large size and weight of the eMMC :wink: I am working on SSD boot and forget the very expensive and rare eMMC. If someone knows alternate sources of compatible eMMC devices, please mention. I am looking forward to hearing about some successful implementations and I will provide what I learn as I go.

I purchased the N2+ (sd card) but having the damnedest time figuring out how to get 1-wire up and running. All the instructions talk about RPi, (which I have running without HA) but none of them flow to the HA N2+ image. hassos_odroid-n2-5.9.img.xz
There is no /config but there is /cmdline.txt file, but no indication of what to drop in there.
I tried some of the configurations for Ubuntu from the HK sites, but no joy.
I about to try modifying the device tree (what ever that is) following this.

I’m pretty sure you’d configure 1-wire on the N2+ the same way as a Pi, but I think you’d be better off starting a new topic for your question.

I was relaying my experience of the N2 installation, not looking for help a this time.
When I am ready I will start my own topic for assistance.

Say what now?

I am floundering at the moment. I was too late to get a Blue, so I just bought an N2+ and 128GB eMMC. I put the home-assistant image on the eMMC and brought it up. As expected, it asked to setup an account and whether I wanted to start from a snapshot. I had just made a snapshot from a working RPI4, so I pointed to that file and it proclaimed it as invalid format. I tried several times from several recent snapshot .tar files and same result. Finally I just entered and I am staring at an overview with not much in it. I am able to use add-on to install samba and that works. So next time I get some time, I will try replacing the config files. Nothing is easy :unamused: :-1: and where are the people trying to work with the ODROID-N2+ talking? Is there a forum group yet? Should be if this is the future :weary:

A bit late I know and not completely relevant but I just bought a 4G N2+ with 64GB eMMC in the UK (not cheap) with HA pre-installed and have just uploaded a snapshot from an HA instance running on a PC (Linux / Hassio) and it worked first time.

I currently have HA running pretty well on a RPi3b with about 35 Zigbee devices and a spattering of WiFi things and it’s fairly reliable. I think some of the issues may be down to overpowering the TI CC2531 coordinator (waiting for CC2652R)?

I did consider a NUC but the 2.2W v 6+W, the fact that I could afford to buy the N2+ new and that it was very small and silent, swayed me toward the Odroid N2+.

HA was also running happily on the slimline fanless Shuttle PC and along with TVHeadend in another container but for technical reasons, I hope to just run TVH on the shuttle (boot from eSATA drive, store video on a 2TB spinning drive) as it has more USB ports (multiple USB tuners) and room for a bigger drive for video storage.

Because I wasn’t comfortable with the whole docker thing or having all my eggs in one basket, I went for the two solutions (well three actually, I have OMV NAS running on a RPi2b with a 3TB external drive). :wink:

Is the Hass OS for Odroid N2+ a 64bit version?

If not, is there any planned? I bought a Blue and if Hass OS on there is 32 bit it’s already useless when I want to use Unifi addon:

This is the final release that supports 32-bits operating systems. Support for 32-bits architectures (armhf, armv7 & i386) will be dropped as of the next release.

Hey there! I am also running HA Blue. I can see from system health that the CPU architecture is aarch64. So, you can assume that it will continue to be supported.

1 Like

Ooh, now that would be awesome news! I do hope it’s indeed also running 64bit Hass OS and not just reporting the CPU is capable of doing 64bit.

Update: OK, got confirmation in Discord, this means the OS is 64bit.

Good! Enjoy HA Blue :slight_smile:

Been running for almost 4 months without any issues at all.

1 Like