HA OS on Pimox (Proxmox V7 for Rpi)

I’m trying to create a HA OS virtual machine on PimoxV7 running on my RPi 4 with 4GB of RAM.

Pimox is a port of Proxmox to the Raspberry Pi, so I don’t know if it’s even possibile what I’m trying to do.

At the moment I tried 2 different attempts:

  • Create a VM with a SCSI cd/dvd drive with the HA OS image for RPi 4 (haos_rpi4-64-7.5.img) to be installed on a disk;
  • Create a VM and import the qcow2 image provided by the alternative installations page (haos_ova-7.5.qcow2)

Neither method allows me to boot the image, ending on the UEFI shell. I even tried to change the boot order as described by this guide without success.

I leave some screenshots of the vm’s hardware and configuration:

Could someone help me? Even just letting me know if it’s theoretically possible?

1 Like

I realize this is an older post … but have you figured this out yet?

I’m trying to do the same thing … :slight_smile:


Here is a video from 26 April 2022 : Youtube It explains how to create a VM using pimox.

HA images might be x86 as well… so it won’t work on a ARM platform.

Didn’t try it, but I saw so some tips during the video. Let me know if you succeed, I am interested to move my lab to pimox.

Did you get it to work?

@rwbrents @vient41 @edoardo
I would be willing to attempt a script to install HAOS on PiMox if I had testers

OK I got this working. Download a release like qcow and import it as a disk and then restore a backup. Works like a charm!

@tteck hanks for your work so far. I’m currently trying out the pimox / ha usecase, so just hit me up if there’s anything to test.

Until then I’ll probably follow @austin17427 's way.

1 Like

@austin17427 what qcow release did you use? I cant find a qcow2 file for arm64

I used this one https://github.com/home-assistant/operating-system/releases/download/8.3/haos_generic-aarch64-8.3.qcow2.xz

1 Like

If anyone is willing to help test a Pi-Mox HAOS script message me.

How did you get the qcow2 image imported ? Sftp is not working at my installation!


I maybe find time this weekend for this kind of experiment :smile:

Step 4 is what you’re looking for here How To Import QCOW2 Image Into Proxmox - OSTechNix :wink:

Just so you know folks, I didn’t like the HA as VM, unfortunately it was the noisy neighbor and reverted back to bare metal. Let me know how is your experience with HA as VM…

I don’t know how did you get that working, now pimox is abble to import qcow2.xz by link. Unfortunatly for me there isnt’t a solution this is the error I get:

BdsDxe: failed to load Boot0001 "UEFI QEMU QEMU CD-ROM from PciRoot (0x0) /Pci(0 x5,0x0)/Scsi (0x0,0x2): Not Found
BdsDxe: failed to load Boot0003 "UEFI QEMU QEMU HARDDISK " from PciRoot (0x0)/Pci
(0x5,0x0)/Scsi (0x0, 0x0): Not Found
>>Start PXE over IPv4.

Any suggestions?

Working PiMox HAOS VM script


That script works perfectly!!!


did a lots of try use YouTube tutorial since most of them were using x86. later realized that even with Proxmox, it needs to follow the ARM arch for Raspberry Pi. Thank you @tteck for providing the script!


You’re a godsend mate. Really appreciate your effort in this. Cheers.

1 Like

hey @tteck
When I run your script with default settings I am getting an error, see below. Would you know what could be the issue?

Using Default Settings
Using HAOS Version: 9.4
Using Virtual Machine ID: 100
Using Machine Type: i440fx
Using Hostname: haos9.4
Allocated Cores: 2
Allocated RAM: 4096
Using Bridge: vmbr0
Using MAC Address: AE:1A:60:DD:FC:F9
Using VLAN: Default
Start VM when completed: yes
Creating a HAOS VM using the above default settings
 ✓ Using local for Storage Location.
 ✓ Virtual Machine ID is 100.
 ✓ https://github.com/home-assistant/operating-system/releases/download/9.4/haos_ova-9.4.qcow2.xz
 ✓ Downloaded haos_ova-9.4.qcow2.xz
 ✓ Extracted KVM Disk Image
 ✓ Created HAOS VM (haos9.4)
 - Starting Home Assistant OS VM...kvm: -drive if=pflash,unit=1,format=raw,id=drive-efidisk0,size=67108864,file=/var/lib/vz/images/100/vm-100-disk-0.raw: The sum of offset (0) and size (0) has to be smaller or equal to the  actual size of the containing file (4194304)
start failed: QEMU exited with code 1
‼ ERROR 255@295 Unknown failure occurred.