HA OS on unRaid!

I just update the OS versions from the HA supervisor and have never had an issue yet.

Uhm ok so I can update HassOS to 4.13 using hassos_ova-4.12.qcow2.gz …


The name on the image just refers to the OS that was used to generate the image. Once you start using it in a VM it is just another virtual disk

1 Like

Hi All

Just installed the VM image and imported my snapshot from my existing hassio_supervisor docker. All went well till I checked my integrations, most are working however am trying to reinstall Plex and Smartthings which both require access to external sites to authorise and every time I complete the process the last page is unable to load. It worked fine before in docker, so am pretty sure its to do with the VM instance not being able to correctly access the sites. Have also tried in multiple browsers.

Is there any suggestions or settings anyone could recommend, have checked out most the guides and cant find anything related ?

@tmchow Thank you!

I was having the exact same issue. Been searching for an answer everywhere and saw your comment here and that worked like a charm.

Thanks again for posting the solution!

1 Like

Ive never had a problem updating. Following the OP guide worked flawlessly.

However, Im having trouble with Zigbee2Mqtt addon. I cannot start it (Zigbee2mqtt Addon install failed) I opened this thread looking for assistance and another user suggested it might be an issue with permission and it could be due my installation. Does anybody have experience with Zigbee2Mqtt addon?

Is there a way where you can host the file system on your cache drive, say /mnt/user/appdata/hassio and have the qcow2 image reference this file structure? From what I have seen, the files seem to be hosted within the VM, which I really do not want.

Ultimately, i’d like to be able to access the files that hassio uses from the unraid platform for various reasons. Is this possible? I know that the SMB plugin is an option, but looking for something a little more direct.

The Home Assistant container from Unraid’s app store does this, but that is a plain Home Assistant install. You would not have the ecosystem with a supervisor and the add-ons, but a lot of those can be found in the Unraid app store anyway.

VMs of any kind are always going to be isolated machines. It’s like asking if any other real computer on your network can host files in that same path on your Unraid box (without making use of smb or something else).

i found this thread by accident… and i think the docker version home assistant is a tease as there is no disclaimer saying this is not the home assistant you want… as i was trying to run that for hours trying to get it to work before i find now you want the raspberry pi hass version running… as a docker is much better uses less resources but what can ya do

so i got this running as a VM i installed the node red but its broken
i get 02 bad gate way… i have uninstalled and re installed several times… but getting frustrated as its not working as easy as the youtube videos… you load the up the vm you wait the 20 min for it setup log in goto add ons add nodered goto load it and bang your in well bang i get bad gateway…

how i fix that? wish there was like 1 video or a setup video that was flawless

1 Like

The docker app in Unraid was available long before HA OS was a thing. It’s not a tease, but an alternative way of running HA.

It should not take 20 minutes to set up the VM in unRaid. One of the main benefits of moving from a pi to an VM was the speed. It takes less than two minutes to get up and running on my machine.

Node-Red takes a while to “spin up”. Are you waiting long enough before trying to open it? Did you check the logs for the add-on?

4 posts were split to a new topic: Node-red not starting

After a server reboot I did notice that Home Assistant did not start. I checked and it seemed started. Looked via VNC and it shows Welcome to Home Assistant, home assistant login:

Why don´t it fire up like it use to? What can I do?

Its like the supervisor would not start.

I can access with root (no password) but I can´t get it to start. ha check leaves no errors

Did a fresh VM and a snapshot restore and up and running, but I´m not happy if this keeps happening every time I reboot the Unraid server. So if anyone has a good idea what is causing this I´m very happy to hear.

There’s nothing wrong with what you are describing.

Okej. Then I don’t understand. If I do a new install the vm boots and I can go to ip-adress:8123

But in my scenario above I don’t get a ip adress. The boot stops before.

How do I manually start ha if this happens again?

I’m not sure what you mean by the boot stops. Seeing the login doesn’t mean it’s stopped. When you login with root, what happens next?

Sorry for late replay. It happend again

Home Assistant will run for some days. In this case like 2 weeks. Then gets strange.

I stoped the VM and started again and if I look via VNC I gets to a promp with

Welcome to Home Assistant
Homeassistant login.

It do not start and shows the webgui as usaually do.

Just curious have you tried building off of debian instead of ubuntu I think I read that is what your running it on, the reason I asked is my QCOW2 instance has been incredibly stable for 6 months now with a ton of updates and beta but I built it on a debian VM funny thing thats the only VM on unRAID that has been rock solid have always had lag issues with other attempts

Still stuck on this?

I added

sharename   /mnt/sharename 9p  trans=virtio,version=9p2000.L,_netdev,noauto,nobootwait,rw    0   0

to the hassio /etc/fstab and it seems to be working.