HA OS on unRaid!

That config looks almost identical to mine.

Anyone know the difference between the network model choices of virtio vs virtio-net?

My vdisk bus is set to SATA vs VirtIO.

mine was too (followed the original post from @cogneato).

I will try to switch Primary vDisk Bus to VirtIO ad Network Model virtio-net to see if performance are better.

Finger crossed.

In the meantime THANK YOU @mrbilky!


Im using the Frigate docker that saves the images to a unassigned drive called Spare

And I want my VM Home Assistant to have access to that drive

I tried this but the VM config just hangs on updating


Any suggestions please?

im guessing I will then need this in configuration.yaml to map the new media share (if someone could please confirm?)

Im wanting to do 24/7 recording and would prefer to use a spare unassigned hardrive compared to a SSD or having to spin up the array

I am using HA in a Vm and frigate as a docker and have a similar problem to you and was going to try figure it out in the coming weeks.

I was going to try mounting a share in HA using something like the following post.

I see you are using an unassigned device. This could create issues with having it available as a share. In my case I have my device mounted as a btrfs pool with only that share saving to the pool.

I might try the Linux host/guest folder option as well now that you have planted that idea.

On a side note I just installed a m2 (a+e) coral tpu in my dell 7060 sff wifi slot and it works perfectly. I also tested it with success in a dell 9020m.

1 Like

To mount a folder under a linux guest you need to use the following config section.

I have never used this feature myself.

@NewToThis This thread has tried folder pass through before without success. I also tried and failed and stumbled on that post while trying to find a solution.

Link to post.

Best bet would be to try mounting a network share using a script.

You could always try get the 9p driver merged into the HA build but that it a real edge use case.

Thanks for the replies :slight_smile: being honest a lot of what’s being said and described is way over my knowledge level (at the moment)

I may have got round my issue anyway… I am wanting to store a week of Frigate data so I have set it up as a Docker with access to my unassigned drive

With the integration and adding this to configuration.yaml (yes i need to sort the icon out)

    title: Frigate
    url: http://192.168.1.(ip of my docker container):5000
    icon: mdi:lightbulb-on

it works fine in HA
Only thing not working is being able to see these files in Media Browser… Which with the Frigate integration I don’t think I need.

Only thing left to get working is to send a ios notify message including the image, I’m hoping that does not need the Media Browser!

I have a odd thing. My qcow2 file gets bigger and bigger. I did set the size to 100 gb when created the VM. I know alot more then I need but I had the space.

Now it has grown and soon no disk left. I have checked the DB size and its like 3.9 gb.

What to do? Start over and set it to 50 gb? and resore from snapshot?


I forget the exact method but you don’t need to start over there is a line of code that will increase the size do a search for it it is out there somewhere I may have even posted it in this thread some time ago

How much space is being used now? You don’t need to let your database grow indefinitely, and you could even delete it and restart HA to start a new one.

You can increase the disk size through UnRaid’s UI https://community.home-assistant.io/t/ha-os-on-unraid/59959/184?u=cogneato

Or you can use UnRaid’s terminal to increase it.

But finding what is responsible for eating up storage and controlling it is going to be a good idea.

In the past you mentioned a command to resize the qcow2 image.
Is it possible to show this command again?

You can resize it in the unraid UI by clicking on the VM name and then clicking on the “capacity” option.

But the command example for using the console was:

sudo qemu-img resize /mnt/user/domains/hassos_ova-4.6.qcow2 +32G

Hi All I am running homeassistant on the VM and I have tried to follow the instructions to get it working using letsencrypt now Swag, I have amended the config file but nothing seems to happen. I got it working on the docker but there were numerous issues with trying to get it to allow the proxy. How do I tell Swag to manage the VM IP?

Thanks that’s it

Sorry for late reply.

It seems like the resize command just adds to the size

My db is like 5 gb big

If I were in your situation I would do a snapshot and restore to a new image. Keep the existing image until your happy you have the new one working.
I have done this in the past and think I am going to do this to the new haos image.

I guess I’m not clear on what you are after. Do you want the db to be smaller? To stop growing?

You can delete it and start a new one, and make use of the docs for the recorder: integration to limit how much data is stored, and what you want to store.


The problem is not the db size. It is only 4 gb.

The problem is that the qcow2 file is very large.

Can I run the resize command but with -50 gb in the end to decrease the qcow2 file with 50 go?