HA OS won't update...stuck at 11.5

Other users have said to look for these messages, as in their case having a custom integration prevented them from upgrading.


The messages tell you the names of the custom integrations as not everyone is aware of what may or may not count, or they may simply have forgotten what was custom and what wasn’t.

I’m not arguing that, I’m simply saying that you will always get these warnings, and they are usually not related to not being able to upgrade.

  1. The “other users” logs differs significant from yours , but you could ofcause just try to disable these integrations ( which is also kind of what these “Warnings” says, And it is as Mentioned Warnings !, if you don’t have any Errors which could lead to these Integrations, i suggest you just ignore these Warnings, otherwise you’ll just get headache every time you look at your startup/restart log.
  2. there is one significant hint in your( sorry, frankiep’s ) “debug log” …

So you could try to run the same “debug command” again, as you should get another result (Error !, doo to the fact it just reported “OK, Command completed successfully.”

So my first thought is , Log Out Of HA , flush everything in your browser cache(cookies included, or check from another device, you usually dont connect to HA from )

I’m not getting that message. Only the warning ones.

Right you are not getting that message, because you probably didn’t run this debug, command, in the HA CLI ( the console of your HA-Device ).
Beside you looked in (talking about) the CORE-Logfile ( And not the Supervisor-log), Nor The OS-logfile

Check your “HOST” log

I’m not getting anything that looks like an error, or even a warning, other than what I’ve already mentioned. Which is why I’m coming here to look for other people with similar problems.

Your problem is, You are not coming here to “look” for other people with similar problems, you come here to SPAM the community, by creating:

  1. 51 Topics in less than 5 month

  2. 0 zero NONE You marked with a Solution !

  3. every Topic made, you seems to just abandon

  4. With your read-time VS Topics & Post created, it seems like you haven’t found the Search-Box either

  5. Compared to the Topics/Post Created and +1.6K “read ?” (doubtful), however you didn’t find any help or responds you “liked”

  6. You are wasting peoples time, People who try to help you

  7. You clearly totally failed to understand what this Forum is about, and missed to READ, the Community Rules/Advices

  8. Now. 23 = 20 Topics created, January 16 Topics created, Please Do the Match

If 100.000 members should create i.e 20 Topics A Day ! , it would be 2 million 2.000.000 Topics. ( In 1 Day ! )
51 Topics in Less than 5 month, would be +5 Millions Topics ! … Abandoned and Not Marked with a Solution

1 Like

Found his ‘won’t update’ in several topics this morning. I posted a solution that would take 20 minutes to implement 6 hours ago :frowning:


Since you seem to be here only to grief other people’s posts, I’m simply going to request that you do not attempt to interact with me in any way that does does not involve trying to sincerely resolve the problems that I’m having.

This is a forum for providing technical support, not for ranting at strangers.

Have you tried what @francisp suggested?

I’m here to resolve a problem with home assistant, not to engage with other users. Sometimes there simply isn’t an update. Especially when someone is repeating something that another user has already said. I cannot reply to every individual post, and this shouldn’t be a big deal for you.

I’m not in a position where I can do that right now. Please be patient.

This forum is not a helpdesk

And thus you can just pass my threads\comment by, and not interact with me.

If you don’t want to be part of the solution then please don’t be part of the problem.

I suggest you try the solution you have been provided, and drop your bad attitude. A community forum is built on engaging with other users, not to resolve your problems. You hereby have the honor of being the first user I’m adding to my ignore list.

Thanks. I spend a lot of time on this forum to help complete strangers, but next time I see a question of you I will just ignore it.

1 Like
 A community forum is built on engaging with other users, not to resolve your problems. You hereby have the honor of being the first user I’m adding to my ignore list.

You’re angry because I didn’t like and share you’re post?

This isn’t facebook.

I tried everything other than scrubbing my system and starting from a backup.

Which you can’t honestly expect me to try so soon.

What error is returned from the user interface?

It seems that the update system fails to apply the update. There are several possible causes, what I’ve seen most often from reports is a corruption in the boot partition or some of the other partitions relevant for the boot. Most often, taking a full backup and reinstalling is the simplest way out.

If you want to continue diagnose the problem, you’d have to check the Supervisor logs (using ha supervisor logs). Also, it might be helpful to show the RAUC logs (using ha host logs --identifier rauc).

hot thread here ehehehe

Btw solved the problem. I have installed HASSOS on BIOS pc following advise listed this thread (at reply #30).
The system booted fine but OS updates does not completed correctly because the system continued to boot previous version.
Here the explanation from trevormcclellan at reply #65:

The reason HA does not boot to the latest version after an update is because the OS writes to the /efi/boot/grubenv file to update the environment, but the default location for load_env and save_env (used in the grub.cfg file) is /boot/grub/grubenv . Setting default to 1 in grub.cfg will work, however, it bypasses HA’s failover method. (HA always has two versions installed at a time, one in SLOT A and one in SLOT B. If one version fails to boot after 3 tries, it will attempt to boot the other version).

Solved using complete guide by trevormcclellan at reply #71

1 Like