HA RBPI static IP without internet connection not booting

Hi guys!

I’m using HA for almost more then a year and I love it.
At this point I have HA running on my Synology NAS at my home, a great extension on my Beckhoff PLC.

For some other projects I’m facing some problems.
The use case is to implement HA on a RBPI 4, in combination with a Beckhoff PLC (trough the ADS component), in a situation where there is no router and/or internet connection availble.

Because there is no router availble, all devices in the network have a static IP adress.
To do this on the rasberry PI, I use this guide:
So I enter the static IP, subnet, also with a default gateway “xxx.xxx.x .1” which is actually not present. Also the DNS is entered, but this is also not present.

Home assisant will not come availble at :8123. Ping is possible.

When I change the network configuration file back to “auto”, and connect it to a network with internet connection the HA instance becomes availble.

So can anybody help me with the settings to use the HA instance on a RBPI with a static IP with no internet connection?

Note: before going into a network without internet connection, the initial HA configuration was done in a network envirement with internet connection.

Thank you !

1 Like

Have you tried this guide also? For changing the network config.


Yes I followed this guide , I used it to make a USB stick with static IP adress.
The adress is working, because ping is possible.

Now with reading it again, it tells me that Hassos need a working time sync to boot.
So what are the possibilities to boot in a local network, with no time server availble?



Local GPS time server


I just found some articles about a RTC. I think a RTC would be a better solution then a GPS clock. (if supported)

I’ll investigate further and will post the resullt


a RTC is definitely cheaper.


I installed Raspbian on the Pi, and manually installed Home Assistant in a docker container.
Did not installed a RTC.

Home asisstant boots, also when no internet connection availble.

Have a nice day!