HACS error?

Seems like I was able to get past and early hurdle only to run into another one (I think?)

Trying to install the custom layout-card from HACS. When I go to download it, I get the following:

It would seem that this is telling me that something is not set right(?) “After the download completes, since you are not using Lovelace in storage mode you need to manually add the resource with these settings:”

Do I need to have Lovelace in storage mode? And, if so, how do I do it? Sorry, just trying to learn (and didn’t find much looking through the forum)

Any help? Thanks!

Follow-up: it looks like this is happening with anything and everything in HACS. Do I have something set or configured wrong?

Again, thanks!

Are you using YAML mode for your dashboards?

Hi, Tom, thanks for the reply.

Have not set YAML explicitly to my knowledge. This is a new HA install just created today. So, if I have somehow set it to YAML inadvertently (and if YAML is incorrect), how do I correct it?

I’m not afraid of yaml, just seems like this is not where I should be at this point. Nothing in HACS is the way I would expect when trying to download any repo.

Thanks again

Plus, have not yet set up ANY dashboards. That’s where I was headed when this issue showed up

Just check if there is a ui-lovelace.yaml file in your config directory. If there is, rename it to something like like old-lovelace.yaml, then try again.

Hi, Daryl - I dont see any such file. I only see:

What do you see in configuration.yaml, under lovelace:

Hmm - ok - no idea then, sorry.

Nothing about lovelace:

Again, brand new installation, nothing there. . .

Here’s a thought, create one dashboard using the UI first.

Created my “first” dashboard, used UI. Still no joy


What version of home assistant do you have installed?

This was the only similar issue I could find and it was for a vey old version of HA:

What does your “Default dashboard” says? is it “UI controlled” , else open it, or edit it in the view , make sure Default Dashboard is “UI Controlled”

It’s in the .storage folder, change your settings in studio-code-server, so you see the .storage folder(dont miss the “dot” )

Please don’t tell new users (or anyone) to edit the .storage folder without sufficient warning.


Let’s close this one out before anyone goes doing harm to their installations…

First, The title here is wrong… This is not an error, it is a hint to you.

You are seeing this because you are using lovelace (HA UI) in YAML mode (you actively maintain a ui-lovelace.yaml file) or in generated mode (you have not yet started to change your UI.).

If you decide to take control of your UI by using the UI (storage mode), you need to restart Home Assistant 1 time after you save your first dashboard for HACS to know about your change.

If you decide to start using YAML mode for some reason, you copy and paste the instructed lines when downloading new custom things.

HACS will only manage the resources when your UI is in storage mode.

1 Like

Ah. That would be it.

This is actually the default behavior, after a new installation(if im not wrong), can be change through the 3 dots, on the Default-Dashboard.
A New user can hardly realize what it means, unless ofcause by trying to “locate” the information in the Docs, or clicking the 3 dots , and hope he/she don’t mess up anything by changing Default-Dashboard ( i don’t know how many users using/enjoying the “Default Dashboard” with auto-implementations of every cards, even if they create a new dashboard, they sooner or later, will change the Default-Dashboard

Generated is default, I use that myself.
A user who wants to use custom things can not use that anyway.