HACS is disabled (Invalid token)

Hi, HACS stopped working, HACS page just says “HACS is disabled (Invalid token)”

And in the logs i can find:
HACS is disabled - HacsDisabledReason.INVALID_TOKEN
August 26, 2021, 8:42:55 PM – (ERROR) HACS
Your GitHub token is not valid

How can i update my GitHub TOKEN?

hi did you get to the bottom of this as i have the same issue currently

I think I had to remove HACS and start from scratch.

Did you try the solutions outlined in the post I linked to?

You just needed to remove the integration and then add it again.

That’s really bad advice.

I’m running an older version of HA because every time I upgrade it, all my integrations break, and it works fine on the older version, or at least it did until I started getting the “HACS is disabled” message.

So I followed your advice, and now I can’t reinstall HACS, because now it wants me to upgrade my entire HA installation to do that, which, my experience has shown, is going to break everything and create at least several days of work for me, which is how long I spent last time trying to get it to work after an upgrade, before I gave up and rolled completely back to the older version and started from scratch.

It would be nice if they kept the system backwards compatible so upgrades didn’t break everything, but seeing as how they don’t, please don’t be so facile about recommending people do something that will immediately cause them to need to upgrade without warning them first that that is the case.


Just fixed this without updating:

  1. Did a global search for hacs and found the line in configuration.yml
      token: "ghp_..."
  1. Checked Personal access tokens and found that yes the token was expired
  2. Used New personal access token page to create a new token
    • Did not check any scopes
  3. Updated the token in configuration.yml
  4. Restarted Home Assistant

And success. I’m running HACS 1.18.0 without it being ‘disabled’


Thank you!

This step is working for me. I’m using the latest HA and it doesn’t have ‘hacs’ entry in the configuration.yaml. Adding ‘hacs’ and ‘token’ to the file works and HACS is now working again.

After I updated a component in HACS then restarting HA, the HACS icon is missing again, and in the log file I see an error message that hacs integration is not available due to invalid token! So, this time I decided to redownload HACS: select the Core tab, and following the instruction.

Then I restarted HA again.

After restart, I go to HA’s integration page, and I see now a red HACS box and it has red ‘RECONFIGURE’ button. I just clicked the button and follow this registration step to get the new token from GitHub.

Restart HA again.

Now, I can see HACS button on the left side bar menu.