Update HACS Access Token

Just got an email from Github about an access token being outdated. It suggest to update the token via github.

It has been so long since I installed HACS and I forgot the process. Anyone seen this email or have updated their token? Is clicking on the update button all there is? No need to do anything else in HA afterwards?

3 Likes

It is now installed through Configuration > Integrations, so if you delete it and reinstall it, it will be authorized through OAuth and you can delete the token in GH. I got the same email.

It’s simple to create a new token on Github as well Follow the link in the email and create a new token with the same scope as listed for the old one.

You don’t actually have to create a new token.

Delete the integration and re-add it and it will use oauth instead.

EDIT: create a snapshot before deleting HACS just in case. One user has borked their install doing this but they restarted after removing HACS (no need to do this).

2 Likes

Some people prefer yaml config for this so it’s easy to make a new token…

2 Likes

So, what is the best way to approach this? Ik am not 100% confident after reading above posts :upside_down_face:.

Remove the integration and then add it back (or if using yaml just update the token)

2 Likes

I had the same email. So you mean the HACS integration inside the HACS menu item itself?
Do I lose all my integrations I have currently in HACS?

Configuration>Integrations. HACS is a HA Integration

2 Likes

Thanks. And this: ?

No you don’t.

1 Like

I can confirm that I uninstalled HACS and performed a new integration. Follow the instructions on the screen. Everything went well and works as before.

Thanks! It worked.
And, just for sanity I can delete the Personal access token I see at github, right ?

Yes you can.

2 Likes

Great ! Everything is fine now :slight_smile:

1 Like

I, too, confirm that uninstalling HACS and reinstalling it again works.
It is safe to delete the HACS token on Github and delete the token in our secret file in HA as well?

If you are now using oauth, yes.

I just deleted HACS integration, then reinstalled but it just gave me a new token and nothing for oauth.
What am I missing?

it doesn’t give you anything. When you add the integration in the GUI it prompts to login to github and then Oauth…

Worked for me, too, thanks, everyone!