Hacs now updating

Hey, i’ve got these on my hacs and it won’t update itself or any of the integrations

Any idea how to fix it?

Look at the issues with Lovelace cards not loading which would keep other cards from loading. Which would stall other things.

where do i check that?

That would be under Frontend as I see on your attached pic

yeah, but my problem comes when updating HACS and Sonoff

when i go inside of them i get these screen for both of them, also the blue uopdate button doesn’t work.

Any idea? Other integratios open perfectly, it’s just those two that i need to update

Yes but the Lovelace cards are also in HACS! So if you can fix or disable those then maybe then HACS will then update.

i fixed those and updated them with no problem now i don’t get the red line at the top on the page.

Same challenge in my installation. Sometimes it will not update. Download icon just spins without completing.

For me, a «hard refresh» of the UI in the browser (Chrome is shift+ctrl+r ?) after clicking Download works occationally. Might be a caching issue?

i don’t even get the spinning when i click download, nothing happens

Next would be to uninstall/reinstall one at a time. It should get the latest version that way.

yeah, but how? i’m not even able to get into the integration page, when i click to go onto the page it just says Unknown error like in the image i sent above

Okay, that looks like a HACS corruption issue. I would google “Fixing a corrupted HACS on Home Assistant”
There are various ways to approach it.

It doesn’t allow me ether to delet the directory

You just can not delete the directory, you need to delete the files first

Just out of curiosity, Have you rebooted your HA host, just to “verify” before you perform such drastic actions ? (and also tried from another browser/device)

Also, which HA version are you at ?, as you seems to have “skipped” a few updates, of both HACS and Kiosk-Mode, then maybe your HA also is a few version behind ?

Im on 23.8.0 and for the os on 10.4. Restarted HA and still nothing, tried from the phone app and nothing. I’m gonna see if i can delete the files and re install it. I have the directory empty and it still says it contains files and i can’t remove it.

That is because they are hidden. Most likely with a beginning period to the filename or folder

I manage to delete everything and now it’s not showing up. To install it again i’ve seen in the hacks website that i need to tun these wget -q -O - https://hacs.xyz/install | bash - but i get wget: server returned error: http/1.1 404 Not Found
Any idea?

Look at this:


sems to be fixed now, is there any way to turn all updates to be done automatically when they release? or at least notify me when there is one without having to open the app?