Could anyone that has got HADashboard running successfully on HASS.IO help out by giving me a a list of steps they needed to take?

I see quite a few people having issues and I’d like to get some better instructions in the docs.



I doubt this helps as I’m not on a raspberry pi. Also I installed Hassio and all dependencies manually because I couldn’t make the NUC installer work on any of the PCs I tried.

So what I ended up doing was just running Appdaemon under docker on the same machine. All my normal settings were copied over and it just worked immediately. I’ve had trouble getting a few of the plugins to work and have assumed they are not configured for x64.

Base OS is Ubuntu 16.04 server, pc is an old USFF second hand dell optiplex core 2 duo with 4gb ram and an SSD.

I would LOVE to see some docs on how to get HADashboard running on HASSIO on rpi3. Personally, I have it (and appdaemon) running via Vlad’s repository but I am stuck on how to get NGINX proxy configured correctly so it works.
For example, my dashboard shows up if I specify port 3030 directly in the browser, but HADASH will not look at that port when getting data from HA.

I know I need to forward http requests on port 80 to 3030, but I can’t figure out how I have to configure NGINX to do that. I am a bit of a proxy noob. Any ideas?


I just got it going, been struggling with this for a few days; just before I got it working I took a step back from the config files and thought to myself that I must be making it way more complicated than it needed to be, and sure enough when I went back to the basics it started working.

With that said I’ve decided to create a post that will hopefully help others who are struggling to get this interface working.

First, i want to thank a couple of users that really helped me in the troubleshooting process, between @aimc, @bager and I imagine those who contributed to bager’s, “My continuous struggle with HADashboard” thread. If you are struggling and my little post cant help to resolve your issues, I would suggest taking a peek at that thread.

Raspberry Pi 3
Hass.io 0.52.1

I did not need any other supporting add-on’s such as Nginx or Dnsmasq, which you will likely see peppered throughout the documentation/forum posts on google.

I think the most simple way to display this is through screenshots.

Here is my appdaemon.yaml file which was created in the hadaemon folder. I’ve tried to make relevant comments where necessary.

Secondly, in the AppDaemon settings in Hass.io>Add-ons, I did not change anything. I left the Options as

“domain”: “http://cp.local.io

and for the Network config section on that same page, i also left the port as “3030” I did not change it to “5050” as I saw in some places too.

As @bager mentioned in this post I too also need to add the “:3030” port in my URL (could this be due to not using a proxy/forwarder?)


More than happy to add more details if anyone is interested, and for those who are struggling I can assure you that it does work on Hass.io despite what you might be thinking right now. :sweat_smile:

1 Like

Thanks - I’ll see about getting this into the docs!

My pleasure, glad to be able to help.

1 Like

@quad1661 Thanks for the great walkthrough! Did you run in to any problems after you added actual components from HA? After I added them, I had issues with them not getting any states, which I found out (After help from, amongst others, @aimc) that it was because the components still got the port 80 in the js config files. Did you experience the same issue, or did it just work. Just curious :slight_smile:

Doesn’t work here. If I add anything other than a simple text box or a clock I get a java error. The best I can make out is that it appears to ignore the fact HA is running on 8123 and tries to connect to port 80.

Later: Modifying the compiled code to remove :80 and replace it with :8123 didn’t work but replacing it with :3030 does. Why is it generating bad code?

I saw another post I think about the version of AppDaemon and it should be version 2.1. I just did a completely fresh install of everything and my AppDaemon is version 2.0.8.


Hey @bager, unfortunately, I am struggling with the same port 80 issue you are. I can change it in the compiled .js file and get it working, but definitly on a ‘save-by-save’ basis, which is far from ideal. I have scoured the applicaiton.js for a place to modify the “URL” function to change the behavior while compiling but I am either not good enough with javascript to make it work or it is being imported from something else in the AppDaemon application.

@bucksbass, it isn’t ideal and definitely not a solution but hopefully, someone with more knowledge on the application can chime in here but if you are looking to make the application work you can update the port 80’s in the compiled .js file as shown below (highlighted).

Changing them to port 3030

Then save the compiled .js file and refresh your browser, it should render correctly from there, kind of a pain but for the time being will be my bandaid.

I think @vkorn needs to update his add-on to pull the latest version of AppDaemon.

I might be barking up the wrong tree here as I’m no expert in any of this, but it looks to me that if 2.1.x of AppDaemon is required, @vkorn’s repository is not going to get it as it’s looking at “pip install git+https://github.com/home-assistant/appdaemon.git@master” and 2.1 is in the dev branch.

So if 2.1 fixes the port issue, either the dev version needs to be put into master or there needs to be an option to select the dev version from vkorn’s implementation.

The fix has been in the master branch for a couple of weeks, so not sure what is happening here. I’ll dust off a pi and give it a try myself.

1 Like

Cool. I just uninstalled and re-installed in case anything had changed. This is my log output

starting version 3.2.2
2017-09-09 14:33:33.237090 INFO AppDaemon Version 2.0.8 starting
2017-09-09 14:33:33.237665 INFO Configuration read from: /config/hadaemon/appdaemon.yaml
2017-09-09 14:33:33.549258 INFO Got initial state
2017-09-09 14:33:33.550643 INFO App initialization complete
2017-09-09 14:33:33.552013 INFO Starting dashboard
2017-09-09 14:33:33.581655 INFO Connected to Home Assistant 0.52.1

Hey @aimc, any chance you’ve had time to take a look at this issue?

So, I spent some hours to understand how this is working, here is the summary:

The addon is pre-compiled to the proper arch image and store in Docker Hub. (So @vkorn should have increase his version number and do a compilation request through the docker CLI to have the latest master version of the AppDaemon.

It is also possible to do a local compilation of the addon, but it takes time and resources and there is a big chance to have an error. (I tried it and still failed) It is also a not preferred method by HA, but if You want to give a chance to that, You can add this repository, which is exactly the same as vkorn’s one, but with local compilation.

Has there been anything concrete on this?, I’ve been reading all of the threads about issues with HASS IO and the Dashboard, each thread says something different setup and each person saying it works (sort of) has a slightly different setup such as using external DNS references, etc.

At the moment I have my configuration files setup like quad1661 suggests - I still get the Java error about getting states (hue lights if it matters). If i edit the javascript compiled files and change the port in them from 80 to 3030, it makes no difference. if I try to expand on the issue by changing the error log paths in the *.dash config I “sometimes” get output but never anything related to the java error - so currently, I’m quite lost.

I came from OpenHab because it was terribly hard to configure, HASS detected all of my stuff without me doing anything which was fantastic - but I’d only use it for the Dashboard so I reallllllly need to get this working :slight_smile:

The solution i am working towards is to integrate the dashboard with homeassistant so no config is required. It will take a little time but that is the plan.


Thanks very much, I love the design and usability of hass but I’m gagging for HADashboard :smile:

If you need anyone to test and of your developments with it, I’d be happy to Guinea pig.

1 Like

@aimc I managed to build an image with appdaemon 2.1.10 and it’s running under hassio.

And I do have a few question too, so drop me line in private so we can go over this.