Hangouts Invalid Login

Hi, I have it working, I think I might have been one of the lucky ones.

I created a new google account and just threw the details in a day or so after the HA version that supported hangouts was release. I didn’t do anything special as far as I can remember, I just followed the guide in the docs and it just worked.

I am running Hassio on HassOS on a Pi 3B, based in England.

I have had a few instances where I have been doing some heavy config tweaking when its had a little sulk at I get errors, but 99% of the time its been fine not that I use it very heavily yet.

Anything else you want to know feel free to ask and I will see if I can answer

Spoke too soon, just thought I would go and check it and right now its not working, my conversations are listed so I am logged in, I just cant send any messages :frowning:

Update: My issue looks to be a know issue in 0.80, things like the conversation list are still updating, so I guess my auth is still good.

I thought it was just me and was hoping the latest Hassio version would have this fixed. I’ve been trying to get hangouts working for the last couple of weeks, to no avail. The setup doesn’t get past the initial login prompt (invalid login every time). I also created a brand new account and enabled 2FA.

I’m running HA 0.80.0, HassOS 1.11, and I’m in the US.

I’ll bump this thread - updated from 0.72 to 0.81 just for this feature. I’ve tried both new and old accounts… none with authenticate. I’m guessing there’s an issue with this integration.

Seems to be marked as an issue in Github:

I can confirm, that both auth and notifications are working for me. So again still not a universal thing. Maybe location or some other similarity for those who are still having lots of trouble.

Location: UK
HA: 0.81.0
Hassio supervisor: 138
HassOS: 1.12
Host: RPi3

I have been battling this for weeks, and finally got through!

I used this:, and just minutes after everything worked!

1 Like

Thanks Skeletorjus…

I have tried 2 old google accounts and allways fails (Invalid Login, please try again.)

Location Spain (Europe), rpi3 with raspbian and HA from 0.77 to 0.81

I have tried the link, even from same raspberry, and no success until now…

Anyway, thanks for sharing the link.

Did you give it time? I had to wait for some minutes before it suddenly worked.

Yes… Wait more than 30 min… Revise configuration, enter from diferent web access, change the main google password, …
No luck

Finally reached with a new account.

Maybe it doesnt work with old accounts.

Thanks for all

I have Hassio 0.81.6 on RPi3 and supervisor 139, based in Switzerland. It’s a week that I’m struggling with the Hangouts integration login without any clue. I tried the unlockcaptcha link above about an hour ago, disabled the pihole… nothing helps! @segalion : you write that you created a new account. Did you take care of anything particular to have the login work?

I created a new account. I checked and I saw there was an access also from an “unknown device” (likely the RPi3 … but always with the error message).
Then I activated the 2FA on that new account but I do not get any 2FA message : it’s as if HASSIO wouldn’t actually contact Google. I restarted HA, but this wouldn’t change anything…
I generated a password for App, but that did not help either…

I only created a new google account, with nothing special. For no interact with cookies of other accounts in browser, I made all with a “private browsing session”. Create the account, and goto the link (on a new tab on the same private browser window).
I dont know if this link has an effect, but in 3-5 minutes I tried again in HA and finally works.

With old accounts was really impossible.

Thanks a lot for the tips, I’ll try again creating a new Google account using private browsing session, but I’m a bit pessimistic because I think it is likely that there is something else that I’m missing. The logs are of no help…

Running into the same issue, with both old and new accounts. Both have been on Hangouts before. In US, have waited ~10 hours and tried again.

I captured some logs from the SSH add-on; nothing that jumps out at me, but perhaps the integration authors might recognize something. I may try taking a look at the code as well:

2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Authenticating with refresh token
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Failed to authenticate using refresh token: Refresh token not found
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Authenticating with credentials
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Submitting form on page ''
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Page contains forms: ['gaia_loginform']
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Page contains inputs: [None, None, None, None, None, None, None, None, None, 'profile-information', 'session-state', None, '_utf8', 'bgresponse', 'Email', 'Passwd-hidden', 'next']
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Submitting form on page ''
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Page contains forms: ['gaia_loginform']
2018-11-09 08:19:28 INFO (SyncWorker_15) [hangups.auth] Page contains inputs: [None, None, None, None, None, None, None, None, None, None, 'profile-information', 'session-state', '_utf8', 'bgresponse', 'Email-hidden', 'Passwd', 'signIn', None]

Did you resolve this?
Having the same problem , have tried difrent accounts with no luck

@Skeletorjus - Thanks this fixed it for me too :smiley:

So, did anyone of you have any luck?

I’ve a quite new account that already works for device tracking but it just won’t accept my login credentials.
I’ve already tried to use the captcha link.

Since Google is killing off Hangouts, you’ll likely want to switch to another messenger service.

1 Like

I never got this to work no matter what I did, I ended up setting up a Telegram Bot and I am happy.