Harmony Hub Detected once

Hello All

Managed to get HA to detect my harmony hub and it created the config files , i then test and could get HA to control the harmony hub.

Since then HA has never managed to detect the hub again (logs indicate its taking to long so gives up), can i force HA to load the harmony hub even though it doesnt think it can find it ?

Hope this makes sense


Thanks used that to help me setup in the first place.

Problem i have is that although it detected once (and tested and fully working), it hasn’t detected since , which i guess means it hasn’t loaded the interface needed to talk to the hub

u try rebooting your hub to see if it comes up? mine usually show up a minute after the front end loads

have rebooted the hub a few time since then still no detection


what happens if you don’t define them and let discovery find them? does it work then?

Just tried that thanks - still no detection

this is the HA log file - seems to indicate a connection problem

2018-05-22 23:18:35 WARNING (MainThread) [homeassistant.setup] Setup of config is taking over 10 seconds.
2018-05-22 23:18:54 WARNING (MainThread) [homeassistant.components.remote] Setup of platform harmony is taking over 10 seconds.
2018-05-22 23:19:16 CRITICAL (SyncWorker_12) [pyharmony.client] XMPP timeout, reattempting
2018-05-22 23:19:44 ERROR (MainThread) [homeassistant.components.remote] Setup of platform harmony is taking longer than 60 seconds. Startup will proceed without waiting any longer.
2018-05-22 23:19:46 CRITICAL (SyncWorker_12) [pyharmony.client] XMPP timeout, reattempting

Thanks for your help


Still trying to get it to work

Do you need to provide username and password for the HUB ?


no you do not, do you have anything new on your network like maybe a new router or something that is not allowing it to connect? Is it on a separate vlan or something?

Thanks for the suggestions, appreciate your help

the hub is wifi (2.4ghz) and the HA on ethernet

i strongly suspect the problem is the HUB not the HA install as have always found harmony to be flakey , router is dualband 2.4 and 5GHZ (no network isolation)

I have another PI running HarmonHubControl which sits on wifi and that can control harmony hub

very frustrating as starting to see the potential of HA but control of harmony hub central to my requirments


hmm maybe try a factory reset on your harmony hub and restore the settings? i have 2 hubs that get detected just fine. both are only paired to 2.4 ghz and very close to the router.

yep good idea, i leave that to the weekend, for some reason a full reset on the harmony never seems to go that smooth


haha yea harmony in general can be a pain…i have an issue where sometimes my remotes dont work…this morning my harmony keyboard lost parts of its configuration and certain keys were not working lol

I had a similar issue whe I first started using HA and was still getting to grips with everything. What I ended up doing was discovery set up the one it found then the one I manually configured but named slightly differently (because I thought it wasn’t found again) created a second but because they had the same up address there was a conflict.

When you say the page to interact with the hub doesnt appear what do you mean? What appears in the list of entities under remote.harmonyhubname?

Thanks for the reply

I think you are right some of the problem is that i am still trying to understand exactly how this all works

when i started , my hue was discovered automatically and configured itself, i added my Yamaha amp manualy and that worked no problems. Then added kodi box which also worked ok

With my harmony hub i couldn’t get it to work, then randomly on a reboot, it picked up the hub, created the config file harmony_xxx.conf. I realised it had worked as it created an entry in the overview tab. I then tested it using the developer tool service and could send a command to the hub and could see it was working fine.

Once i rebooted again the harmony hub doesn’t appear on the overview tab and although it still appears in the developer tools (services) any commands send to it dont work

i have the following entry in configuration.yaml


  • platform: harmony
    name: XXXXXX (have x out the real hub name)


If you have the hub in auto discovery you don’t need anything in the config.yaml. If you want to configure it manually make sure you exclude it from auto discovery - that’s how I ended up with 2 hubs. Also make sure if you do configure manually you use exaclty the same hub name you defined in the harmony app.

thanks again

Sorry dumb question, i dont think its in auto discovery - which is why i manually added it, how can i check ?


In config.yaml if you have


then auto discovery is on and searching for everything including harmony hub.

To ignore certain items you have to set up what items you want to not auto discover. This is mine set to ignore wemo and chromecast.

- belkin_wemo
- google_cast

There is a list in the docs which tells you what to put in for harmony.

Thanks for the idea

tried various permutations, including the ignore discovery / removing discovery / removing the hub config

nothing seems to force detection


I think you also have to delete the harmony_your_hub_.conf file to force rediscovery.

Remove your manual config and turn auto discovery off delete the harmony.conf file plus any other references in groups or customize yaml files. Restart home assistant. Then re enable auto discovery and restart home assistant. Hopefully the conf file will reappear as harmony_name_of_your_hub.conf which means it has auto discovered it again. Also you will need to add remote.your_harmony_hub to the front end via groups but no need for any manual changes in config file.