Harmony Remote Card

Control your media device through Harmony Hub with this card.


Options:

Name Type Requirement Description
type string Required custom:harmony-remote-card
entity string Required remote.harmony_hub the name of the harmony hub entity
devices Array Optional a list of devices to add custom commands to. See below for more info.
activities Array Optional a list of activities. Note this will override the default activities shown
vibrate Boolean Optional true vibrate on button push
showPad Boolean Optional true show D-Pad
leftPad String Optional DirectionLeft command sent for the left pad
rightPad String Optional DirectionRight command sent for the right pad
upPad String Optional DirectionUp command sent for the up pad
downPad String Optional DirectionDown command sent for the down pad
centerPad String Optional OK command sent for the center pad

devices Options:

Name Type Requirement Description
name string Required the name of the device you want custom commands on
commands string Required the name of the command in your harmony.conf file for this device. Can be a simple list or a list of objects with name and command properties. Can also be a service call with service, domain, data options
icon string Optional show an icon for the device
hide_name boolean Optional hide the name of the device

activites Options:

Name Type Requirement Description
activity string Required the name of the activity. Must match the exact name in the harmony.conf file
name string Optional custom name of the activity
icon string Optional show an icon for the activity
hide_name boolean Optional hide the name of the activity
entity string Optional set the entity name for the activity

commands Options:

Name Type Requirement Description
name string Required the custom name of the command
icon string Optional show an icon for the command
hide_name boolean Optional hide the name of the command
command string Optional the name of the command in your harmony.conf file.
service string Optional the name of the service call
domain string Optional the domain of the service call
data object Optional the data for the service call

Example config:

type: custom:harmony-remote-card
entity: remote.harmony_hub
activities:
  - activity: PC
    icon: mdi:laptop
    hide_icon: true
  - activity: XBox
    name: Xbox One
  - activity: PS5
  - activity: Shield
devices:
  - name: Media Room Shield
    commands:
      - Mute
      - Home
      - name: Power Off
        command: PowerOff
  - name: LG TV
    icon: mdi:television
    hide_icon: true
    commands:
      - Mute
      - Info
      - name: InputHdmi1
        command: InputHdmi1
    show_pad: false
  - name: Denon AV Receiver
    commands:
      - Mute
      - Info
      - InputTVAudio
      - InputGame
      - name: Volume Down
        command: VolumeDown
      - name: Volume Up
        command: VolumeUp
      - name: Lights
        service: toggle
        domain: lights
        data:
          - entity_id: light.main_lights
2 Likes

I can’t find this anywhere in HACS. Do you have any ideas what I may be missing?

Frontend - explore

Finally a Harmony Remote card.

Fairly new to Home Assistant. Have installed via HACS, how would I switch my one and only ‘WATCH TV’ activity? Which card in Lovelace dashboards do I use and how would I code it? I don’t need it to do anything other than run the activity.

That’s where I’m searching. I did find a Harmony Card, but not this one.

I don’t know why the card isn’t showing in HACS. However, if all you need to do is stop / start the activity

then you don’t need any custom cards as many of the built-in cards can be used. Th simplest way is to enable that switch you’ve got configured, then you can put it in an entities card, or button card, or glance card.

Here’s one in the button card:

show_name: false
show_icon: true
type: button
entity: switch.lounge_firetv
name: Fire
icon: si:amazonfiretv

@doomi is right.

The card doesn’t appear in HACS. I have the wrong one. I could really do with this one @ljmerza

@eggman That worked thanks but could really do with this remote card :frowning:

doh sorry about that. i forgot to actually submit to HACS. that submission is here Adds new plugin [ljmerza/harmony-remote-card] by ljmerza · Pull Request #1572 · hacs/default · GitHub

I’ve added this through HACS and it is showing in the HACS list of Frontend add-ons.
I’ve also checked and the files have been downloaded to config/www/community/harmony-remote-card

When I try to use it though it doesn’t appear in the list of cards when trying to edit the dashboard, and if I try to enter the code manually it says, “Custom element does not exist”.

(I’ve tried both custom:harmony-hub-card as per the example on Github and also custom:harmony-remote-card as per the docs).

1 Like

Hello, thank you for this nice card ! Was waiting for something like this :slight_smile:

I’ve got this simple conf

type: custom:harmony-remote-card
entity: remote.karmair
devices:
  - name: bboxTV
    commands:
      - Mute
      - Home
      - PowerOff

device bboxTV is present in harmony.conf

....
},
        "bboxTV": {
            "commands": [
                "PowerToggle",
                "0",
                "1",
                "2",
                "3",
                "4",
                "5",
                "6",
                "7",
                "8",
                "9",
                "Mute",
....

but specific commands do not work (nor the arrows), I’ve got this error in HA.log

2022-12-02 19:40:31.542 ERROR (MainThread) [homeassistant.components.harmony.remote] KarmaIR: Missing required argument: device

Any idea what’s wrong ? :frowning:

P.S : I tried to send the command Mute to bboxTV with service Remote: Send a Command, it works, so I think there is a problem with your code

1 Like

For me, the situation was: i installed the card through HACS, it was showing in the list of cards in HACS Front End-section. But when editing a dashboard, it did not show in the list of available cards. I restarted my HA-instance, which did not solve the problem. But i switch of (with a smart plug) my settop-box (and harmony hub) during the night & day-until-the-afternoon: as soon as i powered the hub and the Harmony finished booting, HA showed the status of the Harmony Hub entity online and the card i added manually (so: edit dashboard, add card, at the bottom there is a manual option, paste the example config from the developer (using the entity name of your hub) ‘sprang to live’/populated.

Having the same issue as tk3, Activities work, but individual commands do not. Have tried with and without command names as shown in example. Can also manually send command with no issues. Much prefer your layout and would like to get it working.

type: custom:harmony-remote-card
entity: remote.harmony_hub
devices:
  - name: Family Room TV
    commands:
      - name: HDMI 1
        command: InputHdmi1
  - name: Surround Sound
    commands:
      - name: Volume Up
        command: VolumeUp
      - name: Volume Down
        command: VolumeDown
      - name: HDMI 1
        command: InputHdmi1

Have also tried with various quotes just in case. No dice. Logs error Harmony hub: Missing required argument: device. Tried adding id: from Harmony config, no dice.

1 Like

What is the logic behind the order in which devices and activities are showing in the card. I thought it might be the order they are in the Harmony.conf-file in HA, but that’s not it. Doesn’t seem to be the id of the device/activity in that file either… Would be nice if we could manage the order in which activities and devices are shown on the card…

2 Likes

I also have the same issue as tk#. Activities ok, but device commands do not work with the same error message in the log file.

Same on my Installation. Any Ideas how to fix this?

@ t3k,@ sadsephiroth, @ psawerf
found a solution:
-open file “harmony-remote-card.js” in Folder www\community\harmony-remote-card\ in an Texteditor
-Scroll to the End of the file, line 8844
-Replace: data: { command: e, device: n.device },
with: data: { command: e, device: n },

so remove the “.device”
-not sure if necessary: delete file harmony-remote-card.js.gz in the same folder
-restart HA
-delete Cache in your Browser
-delete Cache on your Mobile HA App if you are using it

@ ljmerza
can you please check this on your end?
And many Thanks for this Card :smiley:

1 Like

Unfortunately this didn’t solve the problem for me. Thanks for the suggestion though.

So same issue here, activities work but the device buttons done (ie up / down / left / right / centre)

Please really ensure that the Cache of the Browser was cleared and everything was new transfered from for HA Server.

You can check this with your Browser.
Click on the Button F12, then the Dev Tools are openend.
Here you should have the possiblilty to see all loaded scripts and the content of the Scripts:

1 Like

Ah ok think I’ve identified the issue which is slightly different. I was testing using the activity ‘TV (Humax)’ when the device buttons were not responding. But it you look at the image below, although I’m actual using ‘TV (Humax)’, its not highlighted on the HA card as being the current activity (its highlighted the Amazon Fire TV Stick device). When I selected the ‘Firestick’ activity, the buttons worked (and the ‘Firestick’ activity was highlighted). So looks like for some reason when I’m using the ‘TV (Humax)’ activity maybe HA / card doesnt know so isnt sending the right commands?

Let me know if you need anything else. Thanks.

hey sorry about the long wait, got busy with work but v 1.4.3 should fix the device issue

1 Like