Has anyone used BG Sockets (UK)

so after a little digging and a lot of failing i eventually found if you download the broadlink universal tv remote app not the standard broadlink app you can add the socket and disable the lock. it then connects to ha without issue. either the name of the app is misleading or the function of the app is misleading but it works and I’ve now got it on my ha dash.

1 Like

Does anyone know if these sockets can be used to monitor energy consumption in ha

No, no power monitoring unfortunately

Does anyone know of a socket with power monitor?

I use Aurora Aone Zigbee ones, but the company has gone now so a bit scarce. You can find them on ebay sometimes

Discussion here:

I use either shelly 2pm or sonoff… actually sonoff never failed but the 2.5 shelly I had before all died (15 of them)

A socket with built in power monitoring I feel would be very cramped and run hot… but maybe there is

Has anyone had any luck pairing the BG extension leads? I can’t get the Broadlink app to pair mine, it seems to pick it up but says it can’t pair with it, with the following error:

Adding device is failed

The device is connected to the network, but the current account location does not match the user area supported by the device, so the device cannot be added to the account.

Please find the outer packaging of the device to confirm the area where it is used

We recommend that you delete your current account in your personal center and then re-register for another account. When you register, set the region as the user area that the device supports. Once you’re back in, you can discover and add the device on the home page.

There’s no “area” on the packaging, but the lead was bought from Screwfix in Ireland, the packaging is english, and the server is set to Europe; I have 6 BG sockets around the house working fine.

I can actually pair the lead in in the BG Home app, also using the European server, but of course I can’t unlock it in that app.

Is there a knack to the device? The instructions say to hold the master button down for 5 seconds, but I don’t get a quick flash for 10 seconds. There is also a slow red flash occasionally, and an alternating blue/red pulsing, I assuming one of those is AP mode.

Hi All,
Just a quick update, I picked up one of the 900 series today, and using the Broadlink app, I was able to connect the device to the wifi, unlock it in the app, and then add it to home assistant without any issues.
It was pretty easy and painless, there are a couple of caviats that you should be aware of if you are still looking to set these up:

  1. The app complains if you’re connected to a 5ghz wifi, so if your 5ghz and 2.4ghz wifi are the same you’ll need to disable 5ghz.
  2. If you have firewall rules blocking internet access on your IoT network the app will not configure the socket properly and will fail when you get to the “name the sub sockets” section.

If the socket is in AP mode, press and hold the left button for about 5 - 7 seconds and it should start flashing quickly, i misse dhtis the first time, so had to start again. - My advice here would be that if you’re configuring these devices; do it on a fly lead that you can plug into the wall and power cycle if required rather than having them installed and then configuring them - maybe preconfigure and label then ask the electrician to install for you if you’re not doing them youreself.

Other than this it is reasonably straightforward. I have just seen that Screwfix does Knightsbridge smart sockets with power monitoring.

Would be good to know if this can be integrated into HA.

incase anyone is interested it looks like the knightsbridge sockets also work.

Hi all,

I’m hoping someone can help me out with these sockets as I have 2 of them and can’t appear to get them into a state prepped for HA.
I’ve had them working fine for a couple of months using Google Home and the BG Home App but this app doesn’t have an option to “unlock” the sockets for HA
From what I’ve read here, and on other forums, the app I’m supposed to be using is Brodalinks Smart TV App which seems stupid but whatever.
I’ve put tried putting one of thee sockets into pairing mode but I’m not having much luck getting the Broadlink app to pick them up. What I’ve done:

  • Press & held the left socket
  • Waited for the right
  • Opened Broadlink App
  • Clicked “Add Device”
  • Selected “General WiFi Device”
    At this point I tried both the “AP Setup Mode” and “Smart Setup Mode”, with no success.
    When I tried the “AP Setup Mode” the app just wouldn’t do anything, I’d get the socket to broadcast it’s AP network (flashing the right LED red) and my phone would join but the Broadlink app kept telling me to join the sockets AP network and would not progress any further.
    When I tried the “Smart Setup Mode” I knew I’d run into issues because I have a Google router which doesn’t allow me to make a distinction between the 2.4 and 5 bands, my solution after some googling… get my spare phone and set it’s hotspot SSID and password to replicate my router settings and turn power off the router. This had some success because I saw other devices join my phone’s network, and indeed, one of the sockets joined it as well (not sure if it was the pairing one or the one paired to BG Home), but the socket never seemed to connect. The pairing screen on my phone told me the phone was connected but the wheel just kept spinning on the device (the socket) connected and the red led would eventually stop flashing and then I’d get a prompt “is led still flashing” and then the pairing would fail.

I’m really not sure what’s going wrong, Does anyone have any thoughts?

Edit: I eventually got it to work; not really sure what I did. I think I’d left one in an unpaired state for so long that it just unlocked itself because one day I went to add it to HA and it just worked with no involvement to the BG or Broadlink apps, although after it paired to HA I was able to pair it to the Broadlink app. My second socket but decided to pair itself to HA with no fuss after the first one paired.