Has anyone used BG Sockets (UK)

Just checking if there’s any integration for BG Sockets

And if it can be flashed maybe with Tasmota/ESPHome and if it has a power monitoring version…


I think someone got it working here:


Bit of an old thread here but I bought these BG Sockets last week and tgot them working using the BroadLink app and then in HA they were found by the BroadLink integration. The only thing I had to do in the BroadLink app was unlock the device.
I would however note at time of purchase there were two models available albeit at the same price. 800 and 900. I bought the 900.

There was a firmware waiting but I got the Sockets working before the firmware so I would advise to skip the firmware initially to see how you get on, however after the firmware update I was still able use them with HA.

1 Like

hi, i might buy some of these sockets - any thoughts after a month of use? any other products i should consider?

i was expecting to get something from aliexpress but £16 on the highstreet seems reasonable. a little toooo reasonable maybe? is there/what’s the catch?

I have 5 of these and are a bit tricky to get paired but once done they work fine.

I do have one that disconnects from WIFI every 5 mins or so, might be faulty and all the others, never disconnect.

There are these I spotted a while back, using Zigbee instead of WIFI, a few more quid though:

Don’t buy the ones from Aliexpress, they have been recalled due to a safety concern:

awesome, thanks for the info. just to confirm, once working with hassio they don’t need internet access - just local wifi?

Yes that’s right, as far as I know but my internet is always on

1 Like

Has anyone tested the zigbee ones?

I don’t understand how more in chrome aren’t available. Only ones I can see are the ridiculously priced light wave ones.

These are in sale at Screwfix today, £11.89

Hi! Just wondering how you managed to use the BroadLink App to register the socket, as I couldn’t figure it out. Any help would be appreciated. Thanks!

The BG app and the Broadlink app appear to be the same. I could not get either app to connect at first but eventually the Broadlink app connected using ‘General Wi-Fi device’ + ‘Smart set up’ mode. At the start of this mode, you need the socket led’s to be flashing really fast - press and hold the left on button for a few seconds. If they are flashing slow long press the left switch again. During the setup they change to slow flash which I think is the socket turning on its AP. It took a few minutes but got there in the end. You have to use the app to unlock the socket before adding to HA - on socket page top right, 3 dots, ‘General’ turn ‘lock device’ switch off

If you search on here for Screwfix someone has detailed exactly the steps needed, without going through the whole pairing process, just the start of it

I have one of these sockets and the app but i cannot find in the app where to unlock the device. I have looked in on the socket page, general, but do not have the “turn” page/ lock device. I have uninstalled the app and reinstalled it, reconnected the socket but still no lock device setting. I cannot even edit the socket in the app. I am admin in the app to so should be able to edit everything. Could this be as i am on their european server and they won’t let us brits to alter things. Stuck right now.

update. Just loaded the broadlink app. The BG app does not have the lock function where the broadlink does. should hopefully now get it integrated into HA.

1 Like

Found this old thread and wondering if anyone has gotten further? I have 8 BG Sockets. I also have a Broadlink RM4 Pro. Suddenly, HA now finds new devices, claiming 3 of my sockerts are accessible within the Broadlink app and I need to unlock them but I can’t add them to the broadlink app.

Any one else seeing this or am I missing something obvious here?

Many Thanks

Hi complete newby to HA - just installed today. Trying to get BG sockets following the above comments but fallen at the first hurdle - which Broadlink Android App should I use - there are about 4 different ones:
Broadlink BLE, e-Control, IHC and Universal Remote Control.

I have tried a couple but could not see General Wi-Fi device in either.

Any help appreciated - thanks

This is the one I use


Had to delete my Broadlink account on that app and then recreate it and then it worked perfectly.

Thank you Holdestmade

Hi ceemjay, when you recreated your account in the Broadlink app did you choose a specific region?

I’m getting the message “The device is connected to the network but the current device location does not match the user area…”

I’ve tried EU/ UK but it doesn’t seem happy.

I’ve had these plugs working fine for months and I’ve was “messing” yesterday and now I’ve broken the integration into HA.

Hi Graeme I am so sorry I have only just seen this - I hope you have got it sorted now. If so howe did you resolve it?