Hass command - nothing happens


I am trying to install Home Assistant on my Raspberry Pi 4B (Raspberry OS).
To do so, I used the official guide.
Everything worked fine except from the last step. I let the hass command run over night but it is still running without any message of success or an accessible web interface.

So my last line in the terminal is

(homeassistant) [email protected]:/srv/homeassistant $ hass

Do you have any idea how to fix this or what to look at?

I never installed Core, but I think it’s normal.
Go to http://homeassistant.local:8123 to access HA proper.

As I said, I cannot access the web interface: ERR_NAME_NOT_RESOLVED
Could there be a problem caused by pi-hole?

If I change homeassistant.local to the IP of my raspberry, I get ERR_CONNECTION_REFUSED

Does the log tell you anything?

Open another terminal window and run top to see if there are any activity.
I think its just F1-F6, but it could be that CTRL or SHIFT is required too to switch.

I know some of the installation methods have hit a GitHub download limit and then have to wait for the limit to get lifted again to continue, so patience might be a good idea.

Where do I find the log? My folder //home/homeassistant is still empty

Edit: the folder is not empty, just didn’t noticed the hidden(?) folder. I am new to Linux. But I still don’t know where a log file is.

hass runs with between 0 and 0.3% CPU and 0.9% RAM. I don’t think, the problem is solvable via waiting since I already let the command run over a whole night and nothing happened.

There have been threads about problems the last few days and they have now been confirmed to be issues with Github, which HA use to get code pieces and addons.
Waiting might be the best solution, since restarting will just reset the process.
A low CPU usage could be a sign of a waiting for connectivity.

I’m running HA core in a venv and if i start hass in the terminal i normaly see the log messages.
So there is something wrong with your installation.

Would you tell me, where I might find updates on this issue? Cannot find anything on it.

I have let the command run again since yesterday but it would probably a good idea for me to watch when this issue should be resolved to see if my installation was affected or not.

Around 8 hours ago users in another thread reported that their installation was working again.
If you can then I suggest you install the newest HA version, which was released like yesterday, since it has an update to the GitHub code to address some of the issues with connections to that site.

Which thread?

Updating Home Assistant was the solution, thanks!

Hello everyone,

I managed to install the last version of rust, which solved the failure building wheel for cryptography.
But now i got an other error at the end of the installation, that i could not fix.
It does not recognize the hass command, altough i followed every step of the core installation process described here Raspberry Pi - Home Assistant

I got this warning at the end of the pip installation, i don’t know if it can help …
WARNING: The scripts pip, pip3 and pip3.9 are installed in ‘/home/homeassistant/.local/bin’ which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
Successfully installed pip-22.3.1

Thanks in advance for your help
Kind regards, Pierre