HASS Configurator correct iframe configuration

As per the instructions here, this is the correct configuration for the hass configurator.

    title: Configurator
    icon: mdi:wrench

But this give me an error refused to connect.

I also tried the url I get when i click on the Open Web UI link on the addon itself.

title: File Editor
icon: mdi:wrench

But that simply opens home assistant within the iframe. Like this

Has anyone got this working with the latest version of HA and hass configurator?


mine is: https://*******.duckdns.org/hassio/ingress/core_configurator but i use the cloud service. as you mentioned in your post, i copied mine from the webui link from within the addon.

edit: i can access mine remotely too (not just on local network) hope this helps.

edit 2: you have it open lol. just hit the picture of a folder below where it says “configurator” :slight_smile:

See this post - SOLVED! - Almost: Upgrading to 0.91.4 - DON'T do it and don't upgrade Node-red and Configurator

I was also caught out by this (…again)

1 Like

see my edits in post above. i think its working.

Check this post:

There is a new feature for Hass.io called Ingress. The Configurator addon uses it.
From the official blog:

For the upcoming Home Assistant 0.92 release, we will be adding support to add links to your add-ons to the Home Assistant sidebar via a toggle on the add-on details page. The link will open the add-on Ingress interface, embedding the add-on in the Home Assistant UI. This will make it look and feel like a single system.

After upgrading the add-on, my panel_iframe doesn’t work anymore.
This is related to the question above. Once you enable direct access again, your iFrame panel will start working again. Until the automated panel integration lands in 0.92, you can also manually add a panel that points at Ingress.

A current workaround for the manual configuration is to use:

  - name: hassio-main
    sidebar_title: Configurator
    sidebar_icon: hass:settings
    js_url: /api/hassio/app/entrypoint.js
    url_path: configurator
    embed_iframe: true
    require_admin: true
      ingress: core_configurator

yup, this did it. Thanks to all.

Nice. This code works! Thanks.

this doesn’t work for me i end up with a white screen?

refresh/clear cache

done that but it doesn’t help
i changed the "name: hassio-main"
but that is something thats not allowed

have it working now

where do i have write this manual configuration ?

In your configuration.yaml file

this is no longer required with version 0.92.0

Just to update the post.
WIth the 0.92 is not necessary to add the panel_custom in the configuration file.

Just go the add-on details page and use the toggle Show in Sidebar.
The Configurator will be added to the menu.

Arrrg! Anybody else fallen foul of Chrome on a MacBook when editing config files in configurator? About one time out of twenty I’ll try to pan left with the trackpad and inadvertently end up going “back” in history and wiping out all my edits!! Arrrr