Hass.io 0.65.6 doesn't resolve adresses

Installed hassio. Check config says everything is OK. Wunderground, yr Symbol and Nest don’t work. They’re not receiving data from the internet. I connected via ssh and ping google.com produces the following: ping: bad address ‘google.com’.
ping works OK.

I ran HA (not hassio) on a standard raspbian pi3 for 6 months on the same subnet and with the same IP without problems. I haven’t touch my firewall/router settings since then.

Here’s the error from wunderground:

Fri Mar 23 2018 23:02:40 GMT+0100 (CET)

Error fetching WUnderground data: ClientConnectorError(-3, 'Try again')


Using ssh I edited /etc/resolve.conf and added my default DNS server IP. Rebooted the system and everything works!

I don’t think my edit made any difference because my edit in resolve.conf disappeared after the reboot and “ping google.com” still produces the same result as above.

The weird thing is that I had rebooted the raspi3 several times before without any changes and looking at a tcpdump on the router I can now see DNS requests from hassio’s IP to google DNS and responses to those requests. These request were not present before (believe me I looked - and not just once).

So it works - but i have no idea why it does or why it didn’t before…

Update II.

The original problem reappeared after I edited known_devices.yaml and restarted HA (everything through the WEB UI). All the sensor/devices that are getting their data from the internet cannot connect to their respective servers, because the adresses are not getting resolved. There’s not dns requests coming from hassio.

Rebooted the pi3 three times and all of a sudden everything is back and working…

Anybody knows where the dns settings are in hass.io?

you need to edit the resin.sample file on the card

First thank you for the advice. I was aware of that option, but tried to avoid it because it’s a very impractical solution to the problem.
I did however eventually follow your advice and edited the file to use a static IP, which is really annoying because I have 60+ clients on my home LAN and I manage all their network settings centrally with a DCHP server. Hassio is now the only one to require physical access for maintenance of the network.

But now at least it works with my local DNS.