Hass.io and HADashboard setup - Java error

Hi there,

I installed vkorn’s appdeamon add-on and have HADashboardv2 sort of running. I can display a dashboard with a clock widget. but once I add HA entities, I get and Error saying: “Error getting state, check Java Console for details”.
Is there any way to check out that error? The add-on output doesn’t show anything that hints at an error.

edit: The add-on output shows that HADashboard has successfully connected to HA.

please tell us more about your environment. Are you running in docker, virtual environment, windows, raspberry pi???

It looks like your nginx has wrong configuration

I am running Hass.io on Raspberry Pi 3 with the Resin.io image (docker). nginx is not installed.

Also, the error is displayed in my browser when I try to load the dashboard page.

1 Like

You will need this, which is mentioned in readme :wink:

Please note, right now it’s not possible to have different binding and rendering URLs for Dashboard. To handle this, port 80 is used by default (exposed as 3030 from docker). You’ll need to use nginx proxy, for example this addon works really well

Install this add-on

and add this

      "default_server": false,
      "port": "3030",
      "vhost": "cp.local.io"

Configure your DNS or hosts file to resolve cp.local.io as and IP of your hassio instance.

Unfortunately, without changes in dashboard itself other approach won’t work now, but aimc is working on official support afaik.

In fact now the beta is closed, I will be looking into this next.


OK, so I installed Nginx Proxy for multiple VHOSTS and added

  "vhosts": [
      "default_server": false,
      "port": "3030",
      "vhost": "cp.local.io"

to the “Options” in the Hass.io window. I don’t really understand what you meant with 'Configure your DNS or host file to resolve cp.local.io".
Would you mind throwing me another bone, please?

Your dashboard should be resolved through cp.local.io or any other domain you prefer. In order to do so, you need to setup your DNS server (if you using any) or put into your hosts file hardcoded value

Thank you!!! I got it working with Pihole.

For all the people that aren’t into this topic as much as I am, here is how I did it:

As an option you could also use Dnsmasq which is official add-on. But PiHole is much better in terms of additional perks :slight_smile:

1 Like

Hi @SunMoonStars, bit off topic to this thread - but have you got Pi Hole working on a hass.io Raspberry Pi 3 setup?

I would like to have both (hass.io and Pi Hole) running at once on my Pi, but ever since I started fresh with the new hass.io image I realised I couldn’t easily install Pi Hole too.

I have searched for any tutorials on how to do such a thing, but couldn’t find any.

Do you have some pointers?

Thanks in advance!

Hi All,

Forgive me if you have already answered this question but i’m quite confused with all these new updates :slight_smile:

I have the new Hass.io image installed in my Pi 3. I’ve used the ResinOS image. How can I add Hadashboard to my configuration?

It seems I cannot install Appdaemon.

Maybe you have already written a guide? :slight_smile: If not, can someone tell me how to add Hadashboard to Hass.io?

Thanks all


1 Like

@vkorn is maintaining the official AppDaemon/HADasboard addon for hass.io here.

So that is and will be the official AppDaemon for hass.io? Can it be used for purposes other than HADashboard? I have my old appdaemon config but am not sure how to re-implement it.

It should support both as far as I am aware.

I am still having problems with setting up HADashboard under hass.io.

I have everything configured as described above, but i don’t get how i need to configure my DNS setup?


OK, I have installed the Dnsmasq addon and now it is working.


now I am getting this error, whithout having something knowingly changed …

502 Bad Gateway


what does the log say?