Hass.io crashs before running for 24h straight

Hi everyone,

I’m using homeassistant for over a year now in my home. Works great!

Wanted to give hass.io a try so I set it up in a minimal environment.
There is just one AppleTv added to it, and Tradfri lighting will be coming soon.

But there is already a problem after installation: hass.io seems to crash, it’s not reachable by ssh or web after x hours (between 12 and 24, don’t know exactly).

Is this a known problem with the actual version or am I the only one?

Where should I look for more information?



I’m currently running the latest version and don’t experience the problems you describe.

Have you checked the log files for possible pointers?

I had the same problem as you described.
Hass.io works fine when setting it up, rebooting etc, but then out of the blue it just stops working. No gui, SSH or anything.

This happened a month ago. Just tried to reinstall today. Will give an update if same problem occours.

Hi, I am new with Home Assistant, and tried first with raspbian, but soon changed to hass.io, only i also noticed that it keep crashing. have set it up already for 3 time, now testing my pi2 for stability. (never had issue with raspbian).

I use raspberry pi 2

I had this problems at the beggining. Then I disabled some ffmpeg camera devices and it seems now it’s more stable.

A week ago I updated to last hassio release and enabled again ffmpeg, by now, no problems.

I use hassio on RPI 2.

It has worked now for 1,5 days straight.

Only thing I changed was setting a fix ip in the router (was in this case an old bbox2, users from Belgium will know :see_no_evil:). Maybe there was a problem related to dns or something.

I did that because I saw the LEDS of the raspberry flashing like they do under normal operation, so I thought that I maybe just can’t reach the machine while it’s still working totally fine.

I will let you know if my problem is resolved now!


Glad you found a solution! Happy automating :smiley:

I’ve also had some random crashing on my rebuilt hass.io installation.

Two days ago, it crashed again, would not come back up and eventually I had to pull the plug.
When it came back it had somehow forgotten all my zwave device info, and I had to restore my zwcfg_*******.xml file from a recent manual backup.

No idea why this is happening.

ffmpeg should be fix with homeassistant 0.53 (next release)