Hass.io on generic PC hardware

I’d like to run Home Assistant on hass,io on a dedicated small PC. There was a thread back in the ResinOS days about the NUC, but that refers to NUC images linked on the installation page back then – nowadays, it’s only Raspberry Pi, virtual machines or having a full Linux below.

(I’d like to avoid going the full Linux distribution road because it’d mean caring about any setup in there and updates as well, wheras with hass,io I can update everything from a single web GUI and don’t have anything to backup other than Home Assistant).

My current go-to approach (yet untested because hardware is yet to arrive) is to take the VMDK image, copy its content over to the PC’s hard disk and directly boot from there. Is there a better (documented) way to go about having full HassOS based hass,io on hardware that is not a RasPi?

(Sorry for odd my spelling of hass,io with a comma – the forum software would otherwise interpret it as links and limits me to two links per post.)


Also interested in this. For some reason my PI keeps randomly falling over with HassIo (used to be fine with Hassbian) tried multiple reflashes etc, always seems to just fall flat at random.
Thinking that it may be my powersupply I’ve bought 5 diferent ones over the months and still get the same issues.

I’m weighing up my options as to how to continue with homeassistant, and this is a possible way of getting around my Pi issues but I’m yet to get into Linux properly…

I believe the Hassos images for Intel NUC shouldn’t be far away? The team have the hardware according to a Twitter post but for now, the next best thing would be an Odroid C2 with eMMC storage as Hassos supports those or the Tinker Board S as that has integrated WiFi and BT (unlike the Odroid).

I’m running a NUC with ResinOS and Hassio and hanging for the new HassOS builds and like you guys, I don’t want to manage a Linux distro and associated issues getting USB peripherals working through containers,

Define falling over… Pi problems are normally power supply or SD-Card.

No longer available via web interface. Can’t SSH in and wont show up on my network scans (Via WifiAnalyser app on my phone).

Is there a more robust way of running HassIo other than via a MicroSD? (or possibly, are there more robust MicroSDs?
Currently using a Sandisk Class10 16gb

My latest powersuppl is a “NorthPanda 3A” power supply for the Pi, it’s not like I’m even using a cheap janky phone charger or anything. I figured 500mA would be enough head-room to keep the Pi happy?

Power sounds good.

I was using a Samsung EVO class 10.

Prior to that I had the exact same problems and that was with an SD card that came with the Pi and originally had NOOBS on it. I’d be replacing the SD-Card with either the EVO as per above or there are also some high duty/write cycle cards you can get… the dash camera forums are a good source for info.

When I changed my SD card that was the end of my problems and it was stable for months.

1 Like

Why had I never thought about what Dashcams use!!!

A 30 second google search resulted in:
High endurance Sandisk/Transcend 64gb for ~£20
High endurance Sandisk/Transcend 16gb for ~£15


1 Like

I’m not actually interested in NUC images – the hardware would be a different brand of bare-bone PC (Shuttle brand). As long as we’re talking about classical PCs (used to call them “IBM compatible”), there should be no need to have per-device images. That’s different with RasPi & co where you’ll need a latest kernel and/or device tree files and possibly additional firmware/drivers, but for a regular PC, a plain generic Linux installation (with a pack of nonfree firmware as it conveniently comes along usually) will do nicely.

Have you tried these instructions? I tested it on my ubuntu laptop and worked fine.

@dodacs, those instructions are about running hass.io on a generic system where a Linux has been installed before.

I’m aiming for the simplicity of a RasPi installation (download image, copy it onto a medium, plug it in, start) on generic PC hardware.

(Actually, it’s not me who’d run the systems – I’d be perfectly fine having a generic Debian installed and only running home assistant on it, but given that a colleague of mine will maintain the system and possibly install more of the same kind, I’d like to keep it as simple as possible).

How is a generic linux install not simple?
One command every month or so to keep it up-to-date.

To you and me, it is. To a novice user who’d first have to pick a distribution, set up a user on the machine and has to log in via that (as opposed to web-GUI-configured SSH access to hass.io, if at all necessary), decide whether the distro requires regular updates or does it on its own, and decide whether larger upgrades are required every few years (for example, Debian can do unattended-upgrades, but that won’t go from one stable version to the next) and considering whether such an upgrade might break anything

– as opposed to running HassOS on a RasPi where you get a nice icon whenever a complete system upgrade is available –

is quite a big thing.

I’d like to understand the discrepancy between the operation on a particular vendor’s hardware (where images are almost the only way of installing things) and generic PC hardware – and whether it’s just that nobody has bothered to build an image file that’s not packed into a container disk format, or whether there are reasons not to do that.

But if no one has built the image, perhaps you can do it to solv the problem for your friend and many others.

Personally I find installing a distro very simple and if it’s really that hard for your friend, write a script that answers all the pesky questions for the install. It’s not all that hard particularly these days.

As I’m asking (admittedly, could have made the title clearer) about how to use HassOS on PCs, an answer boiling down to “You can replace HassOS with a script that installs any Linux distribution” makes it kind of questionable why there would be HassOS in the frist place. Given it has features like different release channels and a integration of a update-and-fallback supporting bootloader and some other good stuff, I’d rather go with something that serious effort was put in rather than hope that a few-line shell script would achieve the same.

That’s what I’ll try as soon as I get the hardware (I did test it on a virtual machine but surprise, a VM image works there :slight_smile: ) – I was just hoping to get a bit of background on the background of why that’s published only as a virtual disk image.

Has any of you tried using Ansible scripts or such to setup RPi from fresh image to working HASS setup? I’d hate to make all configurations to fresh RPi installation.

Status update: I tried now what I proposed – copied the virtual machine image from hassos_ova-1.9.vmdk to a hard disk (vmdkmount hassos_ova-1.9.vmdk /mnt, dd if=/mnt/vmdk1 of=/dev/sdb-or-where-ever) and attached the disk to a Shuttle DL10J (those devices only booting in UEFI mode is a nice fit with the built images).

Various observations:

  • On first boot, the image has grown its last partition to the full disk size.
  • The USB keyboard works during the bootloader, but was then disabled. Could be on purpose, could be b/c the VM image doesn’t expect USB keyboards. (Doesn’t really hurt given there’s little to do on the console).

So far, I did not get a usable system – introspection of the logs shows that docker failed to get some images. Downloading hassos_ova-1.10 to see whether that version just stopped working; stay tuned.

1 Like

With hassos_ova-1.10, I’ve run into the same trouble. From sniffing the network traffic, it appears that the VM image does not get the (Intel Gigabit, I221) ethernet interface up at all. My best guess is that the selection of drivers was cut down for the VM image. Taken to the hassos issue tracker.


I flashed the hassio image for nuc directly on my laptop and all is doing great. But I want to find a way of turning the laptop screen off. Any suggestions?

1 Like

Was there anything special you did for this? I have a desktop I’d like to do this for…seems like it would be going the USB route (Balena, etc) and boot from that to replace Windows. Is that the way you did it? Or am I missing a step in the process?

Interested in going this route to get it off a VM, just wondering how you did it. And since April, have you had any problems with it? (Sorry, I don’t have any answers on the screen problem.)

1 Like