Hass.io on generic PC hardware

Have you tried these instructions? I tested it on my ubuntu laptop and worked fine.

@dodacs, those instructions are about running hass.io on a generic system where a Linux has been installed before.

I’m aiming for the simplicity of a RasPi installation (download image, copy it onto a medium, plug it in, start) on generic PC hardware.

(Actually, it’s not me who’d run the systems – I’d be perfectly fine having a generic Debian installed and only running home assistant on it, but given that a colleague of mine will maintain the system and possibly install more of the same kind, I’d like to keep it as simple as possible).

How is a generic linux install not simple?
One command every month or so to keep it up-to-date.

To you and me, it is. To a novice user who’d first have to pick a distribution, set up a user on the machine and has to log in via that (as opposed to web-GUI-configured SSH access to hass.io, if at all necessary), decide whether the distro requires regular updates or does it on its own, and decide whether larger upgrades are required every few years (for example, Debian can do unattended-upgrades, but that won’t go from one stable version to the next) and considering whether such an upgrade might break anything

– as opposed to running HassOS on a RasPi where you get a nice icon whenever a complete system upgrade is available –

is quite a big thing.

I’d like to understand the discrepancy between the operation on a particular vendor’s hardware (where images are almost the only way of installing things) and generic PC hardware – and whether it’s just that nobody has bothered to build an image file that’s not packed into a container disk format, or whether there are reasons not to do that.

But if no one has built the image, perhaps you can do it to solv the problem for your friend and many others.

Personally I find installing a distro very simple and if it’s really that hard for your friend, write a script that answers all the pesky questions for the install. It’s not all that hard particularly these days.

As I’m asking (admittedly, could have made the title clearer) about how to use HassOS on PCs, an answer boiling down to “You can replace HassOS with a script that installs any Linux distribution” makes it kind of questionable why there would be HassOS in the frist place. Given it has features like different release channels and a integration of a update-and-fallback supporting bootloader and some other good stuff, I’d rather go with something that serious effort was put in rather than hope that a few-line shell script would achieve the same.

That’s what I’ll try as soon as I get the hardware (I did test it on a virtual machine but surprise, a VM image works there :slight_smile: ) – I was just hoping to get a bit of background on the background of why that’s published only as a virtual disk image.

Has any of you tried using Ansible scripts or such to setup RPi from fresh image to working HASS setup? I’d hate to make all configurations to fresh RPi installation.

Status update: I tried now what I proposed – copied the virtual machine image from hassos_ova-1.9.vmdk to a hard disk (vmdkmount hassos_ova-1.9.vmdk /mnt, dd if=/mnt/vmdk1 of=/dev/sdb-or-where-ever) and attached the disk to a Shuttle DL10J (those devices only booting in UEFI mode is a nice fit with the built images).

Various observations:

  • On first boot, the image has grown its last partition to the full disk size.
  • The USB keyboard works during the bootloader, but was then disabled. Could be on purpose, could be b/c the VM image doesn’t expect USB keyboards. (Doesn’t really hurt given there’s little to do on the console).

So far, I did not get a usable system – introspection of the logs shows that docker failed to get some images. Downloading hassos_ova-1.10 to see whether that version just stopped working; stay tuned.

1 Like

With hassos_ova-1.10, I’ve run into the same trouble. From sniffing the network traffic, it appears that the VM image does not get the (Intel Gigabit, I221) ethernet interface up at all. My best guess is that the selection of drivers was cut down for the VM image. Taken to the hassos issue tracker.


I flashed the hassio image for nuc directly on my laptop and all is doing great. But I want to find a way of turning the laptop screen off. Any suggestions?

1 Like

Was there anything special you did for this? I have a desktop I’d like to do this for…seems like it would be going the USB route (Balena, etc) and boot from that to replace Windows. Is that the way you did it? Or am I missing a step in the process?

Interested in going this route to get it off a VM, just wondering how you did it. And since April, have you had any problems with it? (Sorry, I don’t have any answers on the screen problem.)

1 Like

Did you figure this out? Since there’s no installer, a USB route seems a dead-end. Seems the path would need to be pulling the HDD from the laptop, connecting it to another PC, then burning the drive with Etcher, before returning it to the old laptop.

Hi, I tried to install home assistant Os from a bootable USB to a Compaq laptop and it is not working.
Tried also what you Tarheelz advice but still not working.
Any clue why and how could it be possible?

Why not simply use VirtualBox to run HASSIO on.
It runs for 7 months now, best thing I’ve done to move it from the Pi.

Thank you for your reply. It’s an old laptop Compaq Presario q60. I thought that running a lubuntu 20.04 OS plus VB plus hassio could have been too much. I was particularly interested in motion eye add-on. So I installed the supervisor home assistant. it looks like it is a bit heavy. However I’ll configure motion eye today and see.

ok, hopefully it works for you !

Tried It and it’s too heavy for my laptop. I decided to use only Shinobi.video to manage my IPcam. And that’s it.

the x32-x64 should work that way but etcher didn’t work with the 250gb ssd i had. and after using another similar program for it the network isn’t working( aka no ip adress is taken)

this is how i got it working