Hass.io on NUC - authorized_keys sync

Error observed during installation:

[FAILED] to start SSH authorized_keys sync.
See ‘systemctl status sync-authorized-keys.service’ for details

Image: resinos-hassio-0.8-intel-nuc.img
authorized_keys file copied to root of USB boot drive

My Intel NUC does not have an SD slot, so installation is from USB. Installation works fine, but authorized_keys seem not to get copied over b/c SSH on 22222 fails with error ‘Server refused our key’. Tested with RPI version on RPI, same authorized_keys file, and it works fine.

Observed variance in boot device name, not sure if relevant.

  • RPI image on micro SD as ‘resin-boot’ - authorized_keys get copied and can ssh
  • Intel NUC image mounts on USB as ‘flash-boot’ - cannot ssh

Am I doing something wrong?

I had the same problem. I then just copied the data from the PuTTYgen window and pasted it into the “authorized_keys” file. Check out this thread with the ssh video, I guess it’s the same problem (carriage returns).

Thank you for your response. I have been successful using the SSH addon. My challenge exists getting ssh access to the Hassio ResinOS image specifically on the NUC platform. ResinOS image for RPi I have been successful.

I place the authorized_keys file in the root of the boot partition on the installation USB stick, but it seems it doesn’t get copied over during the installation. The same procedure with the "Hassio Resin RPi mage seems to work fine.

Did you get this to work?

I´m about to test Hass.io on my NUC and I am missing a SD-card slot too.
Did you extract the img to a USB-drive? Does it then install into the local SSD on the NUC?

Yea, I used Etcher to put image on a usb drive, and it installs to the internal SSD. Both 0.8 and 1.0 versions did not copy authorized_keys to the SSD for me. I have HASSIO on a few RPi and they authorized_keys worked fine.

If you load the SAMABA addon and it throws a bunch of errors, interface not found, the interface on the NUC is eno1, not eth1.

Thank you @azbutz.

Do you know if this has been addressed and will be solved in 1.1?
If so I might wait unless it is easy to fix.

Since you run HASSIO on both NUC and rPi. Did you notice any benefits running on NUC?
Thinking it might be overkill run it on a NUC if rPi is fully sufficient.

I have my current HASS installation on a rPi2.

I have not tested 1.1. No one else confirmed they also had problems with authorized_key sync on NUC, so didn’t post as an issue on github. It could be me.

With RPi the database was too slow, so I used an external MySQL database. Many posted they believed the performance bottleneck was the SD card. With the NUC I put the database back local on SSD. I’ve been using the Addon MariaDB. The performance is ok, though seems no faster then when I used MySQL on a VM on a esx cluster.

My i5 NUC with 16gb of RAM is probably over kill, but as new addons are developed I have capacity to add new services.

We need fix that, but I don’t know when I have time for it. Maybe some one will help to fix it: