Hass.io on VMWare ESXi 6.7 - Step By Step

Yep, 192.168.15.x is the local subnet. For this, I have rebuild another esxi server and deployed another Hassio host vm. But it is still the same. On the same subnet, .35 last octed.

can you ping host ? you are using http right? and not https ?

do you have the righ ip?

Look for the IP with

  1. login
  2. ip a


because in the vmware Center its shows and you said (picture)

that .35 is probably on his other esxi server , so my guess the ip’s were right

Really appreciate your contribution. Yeah, Fabio is right. It is on second hardware. So! I’ve installed ESXi on a desktop this time, thinking the one on the laptop might have some low-level networking issue. But it was not the case.

I am still not understanding when I have installed Hass.io through docker on Linux, only then I could access the web interface. However, I wanted that running independently as a separate VM along with my other servers.

All I have done is run the vmdk file as Fabio’s instruction. I haven’t even made any change on it.

1 Like

Hi Fabio,
Thanks for help me with it. Yeah. I’ve tried both. Http and Https. Tried even different browsers. ::frowning:

no idea whats wrong :frowning: everything looks ok to me

Thanks anyway, at least you’ve tried. To be honest with you, it is not making sense to me at all. I don’t see anything wrong with it. Anyways, I’ll keep trying.

Ok :wink:

Are you able to ping it? Maybe you can start from another HassOs release? Like download HassOs stable 2.x , afterwards it can be upgraded to 3.x

I have the vmdk installed in my esxi. It booted up no problem. But it’s been stuck at “preparing home assistant” for 2 hours. Im guessing it’s actually hung up now. Just wondering if there is an easier way to play with hass.io. If i had an unused pi to do a full install i would but i have none free at the moment.

Hmm, strange, what are you setting ? I use Linux 64 bit

what do you mean what am i setting? as far as the OS? i used what i found regarding setting it up. debian 9 x64 if that’s what you mean :slight_smile:

yeah, for the OS, i use : Linux 64 bit , Network: E1000 , IDE Boot: UEFI
thats about it

i got back from lunch and it’s ok now. No idea why it took so long. But it appears to be fine. So off i go to play now!

Tried it on ESXi 6.0 but it doesn’t finish booting up. It just loops forever along the network region of the boot-up process. Any help appreciated.

can you make some screens your config?

Nope. I can’t even get into the web interface (x.x.x.x:8123). It just says “This site can’t be reached. x.x.x.x refused to connect”.

I can ping its IP address, though.

This is the VM network config.

That’s not esxi? Right, I think it’s Virtual workstation? Do you get an IP from your local lan?

Trust me, it’s esxi. That’s a screencap from the vSphere client I use to manage the host.

Since this is a fairly old host hardware (HP Microserver N40L), i kept it at esxi v6.0.

Did you change the bios version? I use Linux 64 bit as OS … Rest is default for me… It works