Hass.io on VMWare ESXi 6.7 - Step By Step

You are using http right? And not https
Default it’s http, you need to change afterwards

It gets an IP and I can ping it. I’m sure of the IP address because the ping stops when I restart the HA VM… aside from the fact that it’s shown in the VM’s Summary tab.
I selected “Debian GNU/Linux 8 (64-bit)”.
Tried both http and https… no dice.
Here are a couple more screencaps. Don’t know if it helps.

What do you see in the console view?

It just loops like this…

Can you try do disable ipv6 ?

I never tried to enable it.


What does your wider network look like? Any firewalls or DNS proxies / blockers?
I ask because whilst I use Microsoft DHCP and DNS servers and PiHoles to filter out some garbage, my Home Assistant instances still attempt to access Google DNS servers. This might be because of an add-on or integration I have but here is a link to my asking about this behaviour a while ago…
If your brand new HA instance cannot resolve URLs via DNS for any reason you might get something like that.

I have Untangle firewall and a local Microsoft DNS and DHCP server.

The firewall/web filter blocks certain categories of sites like pornogrpahy, known malware sites, ads, and such, but it’s generally non-restrictive.

I have an older HA instance running on a Pi2, which I’m planning to retire. I never had this issue with the Pi and they’re on the same network, getting their IP addresses with their DNS queries being serviced from the same Microsoft server.

As step 10 states, Hassio on ESXI needs an IDE drive.

Big DISadvantage of IDE in ESXi, is that you cannot snapshot it. Pity!

I tried to convert the disc (vmdk) to SCSI (deleted disk, added SCSI adapter).
Alas, no luck: the VM will not boot.
Anybody having better luck? Any options that work?

I make snapshot, no issue with ide

May work when powered down?
Warm quiesced snapshot is not possible however with IDE.

yes, indeed, i always turn the system off, when i do a snapshot

install on esxi 6.7 ,i can’t found any history log, is this a bug?

That is a bummer. Why build this with IDE?

1 Like


first thanks for your tutorial, works perfectly with my esxi 6.5

but i can’t make update on web interface or on esxi console with “core update”

my error:

20-03-19 08:49:33 ERROR (SyncWorker_6) [supervisor.docker.interface] Can't install homeassistant/qemux86-64-homeassistant:0.107.1 -> 404 Client Error: Not Found ("no such image: homeassistant/qemux86-64-homeassistant:0.107.1: No such image: homeassistant/qemux86-64-homeassistant:0.107.1").
20-03-19 08:49:33 WARNING (MainThread) [supervisor.homeassistant] Update Home Assistant image fails

how can i make last update without install manualy last vmdk + my snapshot ?

thanks for your help :wink:

That would be done from “within” HA, here:

Although mine is not showing due to I am up to date…

hello, my host is up to date (3.12) but not my HA in 106.5

when i tried to make update i have a error, last time i restart from scratch.

other problem i can’t make add’ons update, i thick is a problem of space avaible on HD, 6gb is too smal

I followed the instructions, but got an error that I couldn’t boot into the homeassistant screen. I checked the log to see the file is locked, the boot screen is as attached. I am very confused, looking forward to everyone’s help to debug this.
Sorry, I used google translate

Hi, can you post some screenshots of your setup? What type of hard disk did you configure

Thanks for your quick help. This is my configuration section.