Hass.io problem with interface after restart


I just got into HA and have some problem with it.
It doesn’t restart, tried it via SSH and pulled the power, doesn’t show the webinterface.
Samba and SSH works though.
Any solution?

I have the same problem. reloading the core seems to work, but restarting crashes the web interface. “reboot” with putty seems to shut the system down without reboot. I have to power cycle to get it to turn back on.

Seems like we have the same problem. If I figure something out, I’ll update. Maybe someone else has an idea?

Seems like more people have the problem:

I’ve had to ‘hassio homeassistant restart’ a few times, checking the HA log via SSH shows it has restarted with no errors but the front end just doesn’t come back. Haven’t had anything more than that so far but was thinking it would be worth adding ‘set up SSH before you do anything else’ as it’s a get out of jail free card in situations like this or if you make a boob in the config files as you lose samba if HA doesn’t restart.

I’m now having this problem too. I clicked Update on Home Assistant in the UI, and HA never came back up. I can mount SMB, I can SSH in using the SSH add-on, but “hassio” commands don’t work in the shell:

-ash: hassio: not found

I have tried pulling the power on the RPi, but HA still doesn’t come back.

I don’t see any info in the HA log since before I clicked the Update button.

Any advice?

Same issue all work except the web gui

Please check the current config with the config check addon before you make a update. Look like a breaking Change block the home-assistant. Also updates from < 0.50 will make a long database update that can take over 20min. Maybe you need delete the database file of homeassistant.

It is also possible that a component will install some modules that are very big (> 200mb) and that can block the start of hass.

If all add-ons work and homeassistant don’t work, it is only a home-assistant problem. Maybe you remove all things inside /config and start a clean home-assistant.

1 Like

thanks for your comment @pvizeli - it helped me solve my problem.
I had attempted to integrate the ios app with my hass.io installation by adding


… to my config file. I needed to Samba in and remove that line from my config file to once again gain access to the hass.io dashboard.

The interface not responding has happened to me after I installed the DuckDNS AddOn yesterday which, at first, seemed to work fine. HomeAssistant seems to be fine, automations are triggering as usual. Also SSH and Samba are working as expected. Didn’t make any breaking config changes since the last restart of the system.

Is there a way to disable an add-on from outside the interface? Or any other suggestions to fix this?

This happened to me right now. Does anyone know the solution?

Same here…

I also have the same problem. the configuratiom file is ok as i did a.configuration check before. This behaviour happened to me several times and i could only restart by switching off power supply. Any suggestions what to do?

When rebooting hassio do it from the hassio menu on the left hand side.

Select hassio then in the top right select the three dots, select restart home assistant. Should fix all your reboot issues. Mine was failing after every reboot before I switched to this method now I can reboot to my hearts content without issue.

Smb should come online even if gui wont and you can check your log for issues in your yamls. Fix those and do a power cycle and you should be off the the races.

I have only been using Hassio for a few weeks… I have faced this problem a few times and it has always been something in the config. A few things I have learned…

  1. install SSH, it will always be up enough to ssh into it and view the logs in the /config directory.
  2. roll back the last change, however minor
  3. install samba to enable easy off pi storage
  4. use snapshots and if worst case reload the flash card and fall back to a previous config copied off via samba
  5. use configurator for config changes and do not close window, it always seems to be up and able to change *.yaml files
  6. restart via ssh or terminal ap with the hassio homeassistant restart command always works, GUI sometimes hangs when the restart command is issued
  7. cd /config and tail -f home-assistant.log during boot to see errors and the system loads
  8. the log file is your friend, very cryptic but will contain enough if studied to figure out what is wrong or at least what section of a *.yaml file is broken.

These are my lessons learned… If desperate, I can install a new image, enable samba and then install my snapshot and have the RPi 2 back up in 30 to 45 minutes. I think this state in inevitable for any of us who are noobs to the tool!



hi, i’ve same problem here. so, i’ve try alot of thing and this is my solutions for my homeassistant

  1. connect into your ssh using terminal.

ssh [email protected]

  1. and then, restart your hassio

hassio ha restart

well done, after that, i can access my homeassistant again.



Hey, I’ve just hit exact the same problem DuckDNS AddOn installed and HA GUI is dead… have you managed to resolve somehow?

@mgrom did you solve this? Same here…

I remoted in to another machine and it was available on the duckdns address :slight_smile: Solved for me.

I’ve had it… going back to 8.4, most stable for me. Updates should be rolling out at a slower pace.
This is ridiculous , to edit a parameter in yaml that had nothing to do with HA (like scan_interval etc) and then no reboot.

Raspberry Pi is the WORST machine for IOT. SD cards are unstable to those insane writes/reads. Stop promoting it as a “server” and start advise using any machine with a hdd/ssd.