Hass.io stops connecting to the network

Hi all,

I guess this is the best place to drop this question, so if i’m wrong, please let me know. I could not find an answer in the forum either.

I experience complete shut-off of hass.io from time to time. The interval is long, it does not happen on a very regular bases, but still is anoying as I can’t rely on HA this way for my automations.

So what happens is that when I try to access HA via the web interface or the app, i can’t reach HA. At the same time Samba (HASS share from my PC) and SSH (Putty) are not working anymore. Ping is dead and I also don’t see the device in my router anymore. Connection to the nework looks ok as I seen the interface leds on my port flashing. I’m running Hass/HA on a RPi 3. I can’t check what has happened since I don’t have a log anymore (reboot by powerdown)

Can anyone give me a suggestion where to look and how to keep (an retrieve) logs for further analyses.



Do you have a static IP address set (in your router’s DHCP settings) for your raspberry pi?

Hi @tom_l. Yes I have. My router is assigning fixed IP’s to a number of devices in my network based on the MAC address. So my RPi running HA is always getting the same IP from DHCP.

Ethernet or wireless?

If even such a basic thing as ping is dead, then IMHO there is a serious network problem OR your whole rpi3 system is dead (HA + underlying linux OS). Has the rpi3 sufficient power? Look at the basic things.

@tom_l: fixed cable
@ dojf: Crossed my mind. But the RPi is new and with an original power adapter. 2,5Amps. I would expect very regular drops with power issues. Seen it before. I agree that ping is very low level. But my router also does not see the device anymore. I will try and keep a close watch to the basics.

But refering back to my question (as I guess this is looking for the famous needle) does Hass keep some logs that are available after reboot (power down)


Have you tried replacing the Ethernet cable?

Is there anything relevant in your router log?

Cable I don’t think The lights on the connector are on and flashing, I know does not say all.Will replace it anyway for test. Router logs: I did not think of looking at them. Unfortunatly I had a power outage yesterday. Will look at the logs next time. Thx

Seeing a common issue with the HASSIO failing after a reboot…I had to rebuild mine thinking I had a corrupt card. I got it runnning, but lost my Z-wave…I’m trolling the forum for an answer and see a bunch of similar issues (non responsive hassio) within the past day…wonder if there was a backend update on the docker side.

Hi @richpunch, this is not a reboot. It works and after some time it drops the connection completely.

So HA is down again. Second day in a row.
Ping: Destination host unreachable.
Samba: down, don’t see the HASS share anymore.
SSH: down, timeout with PuTTy.
RPi ethernet lamps are on, some communication is there with the router.
Don’t see the RPi in the router table as a connected device.
No data in the router log that suggests an error with the device.

Hi All,
I wanted to share an update with you all on this.
The problem is still not solved and it is impossible to find the root cause. Al I did so far is trial and error without luck.
I did:

  • Uncheck DLNA media server in my Netgear R7000 router (found another post where this was advised)
  • Changed my network connection completely (cable + switch)
  • Exchanged my SD card (and started from scratch with a fresh install, but same config)
    Result is still a regular loss of network. No Ping (“Destination host unreachable”), no samba, no front-end access, no access through the app). There is nothing in the logs (I do see the incoming DuckDNS requests, but that’s irrelevant)
    This is really frustrating. I had high expectations of the possibilities with HA. But as it turns out when something like this happens you are screwed, no access to logs after reboot, no debugging possible.
    I run the latest version of HA on a RPi3 (standard HASS.io) image.
    Any help is welcome, I still want to solve this!


Hi, I may have had the same problem. Did you try to disable the Bluetooth BCM43xx? I have gone from constant reconnecting (10 x / hour) to zero reconnects in two weeks…

If Spaceman Spiff’s suggestion doesn’t help I’d be beginning to suspect the Raspi board. It’s easy enough to check the RJ45 socket for dry solder joints as it is a through hole component but it could also be faulty integrated magnetics (there are common mode chokes inside the socket) or the PCB traces or etc… Might be easier to try another board.

Don’t give up. HA is a great platform. I’ve had rock solid stability since I started last December. Just bad luck you have a bad part somewhere.

I’ve been running into this a bunch myself lately. So taking the time tonight to backup my instance and try it on another pi. I have mine hardwired to my home’s alarm system so the the output is about 2.5-3amps and worked fine for a while. the only automation I have running is the presence detection for lights and an auto backup at 3 am. I hope we find a solution for this soon because I have seen this come up a lot laely.

Ralph - 100% I bet this is an SD-Card issue. You need a better more reliable card. I originally used a Noobs card I got with the Pi flashed for Hassio and it did exactly the same every day or so and was maddening. Changed to a Samsung EVO Plus 32gb - end of problem. I am now running off a USB stick but it was the card causing the issue - even what I thought was a good card.

Just take a snapshot, use a new card and restore and it won’t do this anymore.

Hi all,

Thanks for all the replies. @DavidFW1960: I will try replace the SD in time. Need to do that anyway because of the size.
Another thing is the system is up and running for more than a week now. Changed nothing to the system. No hardware and no software. Not even a config change. But… i have Monit looking over my critical hardware from another Pi. I decided to add the HA Pi to this system, basically to be able to look at router logs etc. when HA goes down. And guess what. The system runs eversince. The only thing Monit does is pinging the HA Pi. I will keep it running for a whlie, see what happens. But I still think its something with preconfigured image for HA running on the RPi 3 causing this.
Keep you all posted!


If your using HASS.IO I’d recommend making a back up and reinstalling the base OS then restore your back up as sounds like a base OS issue to me. Either that or your storage medium like @DavidFW1960 said.

I did all that. Flashed a fresh SD card, started it up in the RPi and restored the config. Initially that did not change anything. Same behaviour until I had Monit watching over it.


Do you have some sort of power saving set on your router, sounds like the connection is going to sleep from that end rather than anything wrong with the Pi or your setup, especially figuring your Monit experience into the equation.