HASS.IO -> transfer from SD card to SSD or USB

@paddy0174 Sorry for that. I posted because it worked for me. :wink: didn’t realise some things are not working for others. Beside some parts I found on the internet and used it.

For your last question: With this tut it works great on my RPi4! Rebooted many times because of adding new things in HA. No problems at all…

I initially migrated from an RPI 3B+ with SD card (32GB Sandisk Endurance) over to a Crucial BX500 120GB SSD but didn’t notice any performance improvements. The biggest improvement was moving to a 4GB RPI 4B with the same 32GB Sandisk Endurance card, where I noticed 3 day history graphs (of room temps, humidity etc) were loading up at least 50% faster.

I’m waiting for the Raspberry Pi Foundation to implement official USB boot support on the 4B before I switch back to the SSD to get the full benefits of USB 3 as well.

1 Like

Just to let everyone know.
Most of the USB to SATA cases use simple chips (ASTMedia usually) that run around 25 to 50MB/Sec.
The only USB 2.5" cases I know of that do run fact are the Zalman ZM-VE500 that use ARM chip. This one is expensive (around $70) but it runs 300MB/Sec or so. I did not check the lower models.
I use these and only these USB SATA cases. I have tens of them and all are OK for few years now.

My mSATA with the x850 didn’t work. So got a sata drive with a cheap usb cable and now I’ve finally switched everything. Even got a 3d printed case, but might go caseless cuz noticed the cpu temps got higher.


1 Like

Hi,

what RPi du you have? As far as I know it’s not possible to boot from USB on a RPi4. Correct me, if I’m wrong.

Take a look here:

Yep, Pi4 is only bootable from USB, if you leave a microSD in it. :slight_smile:

Well, I have a Raspberry pi 3.

I flashed a sd card with raspbian and added program_usb_boot_mode = 1 to the test file config.txt to boot from ssd.

but I have a problem, only sometimes it starts by ssd.

can’t always boot from ssd.

would appreciate help

Im using the suggested a3ssd–|--Kingston A400 120GB SSD (SA400S37)–|--Startech USB3-SATA3 adapter (USB312SAT3CB)–|--Y–|--Y–|--bootcode.bin–|----|–

And i am able to boot raspbian from my SSD just fine on my pi3, with an sd card with bootcode.bin on it.

However when I flash my hassos image, I just get nothing. Nothing on the IP address, and nothing on my monitor. I’ve waited for half an hour. Absolutely nothing.

Does anyone seems to know what I am doing wrong?

2 Likes

Check my post above: HASS.IO -> transfer from SD card to SSD or USB

I ended up purchasing a new SSD for 25€ and I’m now a happy camper running off an SSD :slight_smile:

1 Like

this 194 might be a reason.
All it depends on the way how RPi with SSD is shut down.

@jelle2503, I’m not 100% sure what might be causing your problem, but that also happened to me the first time upgraded hassos when I converted to ssd. I think it was due to the new firmware that comes on new hassos installs. If your pi has older firmware (likely if you haven’t yet installed hassos >=3.4), the install process will involve a reboot after flashing firmware. Not sure, but I suspect that if you don’t have a newer firmware yet, the first flash to the new firmware may require an extra reboot or 2 before it runs properly (perhaps the hassos install isn’t handling the initial firmware upgrade properly, or there’s something in that firmware that requires a power off afterwards to setup properly).

All I know is I’ve updated hassos several times since with zero issues. At least 2 of those recent updates also included updated pi firmware. So if you have troubles at first, sometimes persisting to install again, or rebooting the pi when it appears to become unresponsive during install, may complete the firmware install after which it will work fine.

Just a note… it doesn’t actually flash anything. The firmware is in the ‘image’ it does not write to flash on the RPi itself. If you boot the Pi with an old SD-Card hey presto you are back to old firmware again.

Thanks for the insight; excellent info to know. I’m used to the world of arduino with ‘real firmware’, softbricking, etc… so this is new to me. So then it must have been some other random problem that went away after a couple tries.

Someone is working on an automated solution for all this soon, in the meantime I’ve documented the manual steps (tested on RPi 4) here: https://github.com/home-assistant/operating-system/issues/164#issuecomment-602145682

I note that there is still no Raspberry Pi 4 option for direct boot to SSD, and it doesn’t look imminent either. You have to use an SD+SSD configuration. Raspberry Pi 3 can direct boot to USB, no SD card required: https://github.com/home-assistant/operating-system/blob/2e7e0398996c5fb39e566e9d6d72df2975ac9f39/Documentation/boards/raspberrypi.md

2 Likes

The last command:

curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" | bash -s--m raspberreypi3

returns:

bash: line 1: 404:: command not found.

If I go to the site, there are no files there. Can someone tell me what I’m doing wrong?
Thanks

Because you have the wrong link. You can find the correct link on the installation page.

The problem is, if the links get updated by home assistant, the tutorials mostly don’t get updated (understandable).

And you didn’t used the correct writing for raspberrypi. So in the end, it should be:

curl -sL "https://raw.githubusercontent.com/home-assistant/installer/master/installer.sh" | bash -s -- -m raspberrypi3

Holy crap. I even went to the installation page and thought I copy’d and pasted correctly…
Thank you - this worked!

I’m an idiot - this corona thing maybe… dunno.

Many thabks @paddy0174

My pi4 arrived and I have hassos and my snapshot running well, except for mariadb, influxdb, and grafana, using the steps you posted on github… kind of. Initially my ancient lxle laptop failed at this. So I flashed an iso of mint linux with etcher to a usb stick, booted my win pc from that, and followed your directions (I think). I used gparted to first create a fat32 partition (aka mbr), formatted it ext4, and went on from there.

After getting it to reboot using the ssd several times, I loaded my snapshot, saw (as I expected from my research) db error logs. So I uninstalled, reinstalled, and reconfigured the 3 aforementioned db addons, and off it went. Now my ha is much faster, and has room to grow.

2 Likes

hi need some help here…

i’ve followed the steps above…

did the usb boot trick, was able to boot via ssd without sd-card. did all the upgrades and installs without any issues, however when i rebooted raspbian, ,my pi3b refused to boot back up…my SSD and pi3b jujst kept blinking the LED :confused:

Without any errors or logs it’s hard to say… :slight_smile:

Did you remove the SD-card before booting it up?

I’d try one of these:

  • connect at least a monitor to your Pi and boot it up. Should give some kind of error.
  • start again at the beginning, doing all the steps again and take note of every step you do, so it is possible to check afterwards. For example, open a txt file and make note of everything you do, every command you put in and so on.

If your SSD has a LED light, is it working, flashing, anything?