HASS.IO -> transfer from SD card to SSD or USB

A simple ssh command ha os update --version 5.1 must work, but it seems the raspberry pi 4 images are missing in the 5.1 version:

EDIT: It seems a known issue…

1 Like

Anyone solve the system locking up (freezing) problem? Before switching to this setup (SD card + SSD) I had my db on a separate server on the network and it was pretty rock solid except when that server went down, HA would lock up from continuing to try to communicate with the db. I switched to this setup expecting it to solve that problem. Now I get random lockups once every couple of weeks. It resolves itself with a hard reset (pulling the power and rebooting). I’m afraid that if this happens when I am away my HA alarm system will be compromised. @AndrejDelany @bbogdanmircea

I’m using a SanDisk 128GB Extreme PRO USB 3.1 SSD flash drive as my SSD, so no adapter. It does run a bit warm… so I thought maybe it was overheating, but now that I see others are having this issue… I’m thinking that its just this setup.

I couldn’t solve it, so I switched to a Intel NUC.

1 Like

I was able to get the current version running on a pi4. I flashed the install version but used the boot files from 5. Restored with a snapshot and was done. I was getting an error as it was still trying to read from the SD, but it didn’t seem to effect anything. I ran it for about 12 hours then went back to the SD. I’ll wait on HA or save it for when I have more time. SSD enclosure definitely makes a difference. I got nowhere with Orico. The working one was Inateck without UASP. I ordered one with UASP to give a try.

1 Like

The 5.1 release seems to have resolved some of the USB to NVMe compatibility issues. I had tried two different USB 3.0 UASP capable adapters (SSK’s SHE-C325 and Plugable’s USBC-NVME) and both wouldn’t boot with a Samsung 970 EVO 500GB (MZ-V7E500BW) SSD. The Plugable adapter will now boot (though it acted weird at first…throwing a website 500 error as it lost the USB drive, then when I rebooted it to solve that issue, it said it was unable to find the USB SSD 60+ times before booting). The SSK device will still not boot. Stops at the “Read start4.elf” process.

I have had success installing 5.1 RPi4 ( 4GB ) 64bit on a standard Sandisk USB stick. It has been running for over 12 hours and my addons are working fine. I just did a restore of my current production snapshot. I could not get the 32 bit version to boot.

I have been running on a SanDisk 128GB Extreme Pro Solid State Flash Drive for a while now using Raspbian Buster and docker ( links below ) flawlessly for a couple of months, just make sure you are running the latest stable firmware for RPi4. These Flash Drives cost $64 AUD and are super fast. I just ordered another one for the HASS.IO build.

I have an EVO SSD that also works via docker but is overkill as the USB 3 connection limits the speed.


1 Like

I’m running the current version, but using the boot files from 5.1. it’s been running about 4 days now. No problems except it keeps timing out trying to find the SD card. I put the card back in and it stops. I’m sure I’m missing something. More reading needed.

From post 365 above, I think this is what you need

extra lines to the config.txt


This line makes disable the time-out messages for the SD card
1 Like

I’ made the jump to an SSD with the latest OS build 5.1. I’m avoiding the update button for OS but is there any reason i shouldn’t update the Core software?
I guess there is really no reason to do these updates as everything works as is…But for some reason i find those update buttons tempting!

Update to core are indepent regarding to underlying OS

I updated the core software from 0.113 to 0.114 a few days ago and everything is still fine. But never ever press the operating system Update button until build 5 is officially released.

just flashed this beta HA image to usb stick and no other modification ?
like kernel update etc ?

also can you share link of USB stick ?
how’s the performance ?
also previously you were using SD card only or SD card + usb stick ? (data from USB and boot via SD card)

Before flashing the 5.1 image you need to update your firmware, you can do this by following the guide from Tom’s Hardware. Stop using the guide after you have completed step 6.

An alternative guide for updating your firmware is https://jamesachambers.com/raspberry-pi-4-bootloader-firmware-updating-recovery-guide/

Once you have upgraded your firmware, remove your SD card, burn 5.1 onto an SSD or USB stick and boot.

The USB stick I am using for my Raspberry Pi OS (32-bit) Lite / Docker / Hassio build is a SanDisk 128GB Extreme Pro Solid State Flash Drive.

James Chambers also has a great list of speeds of various drives and cards


thank you so much , much improvement in page loading
previously i tried SD card+USB method but didn’t noticed much different

hope stable build will come soon so i can get rid of update button :sweat_smile:

1 Like

Great news, I am glad everything worked out. You asked me previously about the performance of my system. I have just found the bench marks I ran whilst building my Raspberry Pi OS (32-bit) Lite / Docker / Hassio build.
Beachmarks generated using code from https://storage.jamesachambers.com/

“sudo curl https://raw.githubusercontent.com/TheRemote/PiBenchmarks/master/Storage.sh | sudo bash”

Samsung EVO 950 SSD

Category Test Result
HDParm Disk Read 305.21 MB/s
HDParm Cached Disk Read 299.39 MB/s
DD Disk Write 200 MB/s
FIO 4k random read 19375 IOPS (77502 KB/s)
FIO 4k random write 10824 IOPS (43298 KB/s)
IOZone 4k read 30968 KB/s
IOZone 4k write 30474 KB/s
IOZone 4k random read 22614 KB/s
IOZone 4k random write 33359 KB/s

Score: 8760

Sandisk Extreme Pro SSD USB

Category Test Result
HDParm Disk Read 151.29 MB/s
HDParm Cached Disk Read 131.51 MB/s
DD Disk Write 141 MB/s
FIO 4k random read 2995 IOPS (11981 KB/s)
FIO 4k random write 2459 IOPS (9839 KB/s)
IOZone 4k read 23636 KB/s
IOZone 4k write 16635 KB/s
IOZone 4k random read 10876 KB/s
IOZone 4k random write 9757 KB/s

Score: 3622

Sandisk Extreme 32G Class: A1 Class 10 V30 U3

Category Test Result
HDParm Disk Read 38.36 MB/s
HDParm Cached Disk Read 35.61 MB/s
DD Disk Write 31.0 MB/s
FIO 4k random read 2257 IOPS (9029 KB/s)
FIO 4k random write 858 IOPS (3435 KB/s)
IOZone 4k read 7602 KB/s
IOZone 4k write 2018 KB/s
IOZone 4k random read 6101 KB/s
IOZone 4k random write 3041 KB/s

Score: 1137

Running the 64 bit version off hassos on a pi 4 (2GB)ssd now with no sd card.
(Tried the 32 bit version and indeed it does not work.)
And I can say it’s like the pi is on steroids even when you compare it to a sd-ssd setup.
Everything and I mean everything loads really fast or at least faster.
Memory wise I had my doubts about 64 bit because in my opinion it does not add anything useful exept more memory use.(Although I read articles that claim otherwise)
But even with the added memory on a 2 GB pi and a reasonable extensive system I still have more than 600 MB’s of free memory.

Rectify this now at 574 MB’s of free memory and 1281 MB’s of used memory.

So the spare pi 4 4GB will be collecting dust and when the time comes 64 bit is already up and running.
Also in my case the backup from my 32bit system works on the 64 bit version no bugs :grinning:
See this post as a user review :slight_smile:


Hi, thanks.

But we still need to use the sd card after ?

No, you don’t need it when you use HassOS 5.x on an SSD!

1 Like

Thanks for this update guys! I’ve been looking into it for a while now, and this seems the solution.

I’ve just bought my second Pi4 for a parallel build of a new environment. A 4GB this time, and want to use my USB SSD for storage. Booting from it isn’t a requirement to me, but if I can it is a nice to have feature.
I’ve just tried it, and it works with the 5.1 64 bit without any problems. The 5.1 32bit won’t boot however. My question is this. The 32bit is still the recomended version when I check the install page of HassOS. Can anyone point out what the disadvantage of installing the 64bit version is? I read in an old post that GPIO doesn’t work for example. That will be a dealbreaker for me because of some legacy 433MHz transmitter. But it’s also not quite clear to me if this is still the case.
So, long story short:
Are there any (big) disadvantages of using 64bit instead of 32bit?

I am running for more then 4 months now on the 64 bits version. No disadvantages dicovered untill now. Only disadvantage could be the lack of support of local GPIO that is currently no supported yet. Also some addons are not build (mostly user created addons) for arch64, all official addons support arch64. Extra Bonus is that the VSCODE plugin is also working (not available for 32 bit)

1 Like